Web Application is not working after ArcGIS Enterprise portal upgradation to 11.0

606
1
Jump to solution
04-17-2023 11:51 PM
GISFunctionalGroup
New Contributor II

Hi Team,
After upgrading ArcGIS Enterprise from 10.8.1 to 11.0 we were not able to edit and view the application from the Portal's content.
however after downloading the same web app and deploying it in IIS we were getting a login popup saying, "Please sign in to access the item on https://xxxx.yyyy.zzz.com/portal(29789dd947a74e49b5a7b7200f79cd7f)" and asking for the Portal's admin credentials to view the web application (as shown in the attached file).
Similar issue was generated when we have done upgrade from 10.8.1 to 10.9.1 version. 
we have tried the following checks in the application.

  1. Anonymous access is disabled in the Portal.
  2. https://community.esri.com/t5/arcgis-web-appbuilder-questions/login-issues-custom-wab-app-enterprise...
    as per the above workaround we have changed the popup: values to false/!0 as well even though same error persisting again

Anticipating quick responses.

 

Tags (1)
0 Kudos
1 Solution

Accepted Solutions
GISFunctionalGroup
New Contributor II

Hi Team,

The Login Popup issue was resolved by following activities has been done.

  1. Added the new web application item in your Portal for arcgis -11.0v  with the URL of your locally deployed app. This item will function as a placeholder for your locally deployed app.

  2. From the Application settings page registered the app and copied the App ID from the web map settings 
  3. Copy the appId into your locally deployed app's config.json in the appId property

Then the login popup application is resolved.

Reference: https://gis.stackexchange.com/questions/382733/web-appbuilder-for-arcgis-enterprise-login-popup-for-...

 

Regards

GIS Functional Group 

 

  1.  

View solution in original post

0 Kudos
1 Reply
GISFunctionalGroup
New Contributor II

Hi Team,

The Login Popup issue was resolved by following activities has been done.

  1. Added the new web application item in your Portal for arcgis -11.0v  with the URL of your locally deployed app. This item will function as a placeholder for your locally deployed app.

  2. From the Application settings page registered the app and copied the App ID from the web map settings 
  3. Copy the appId into your locally deployed app's config.json in the appId property

Then the login popup application is resolved.

Reference: https://gis.stackexchange.com/questions/382733/web-appbuilder-for-arcgis-enterprise-login-popup-for-...

 

Regards

GIS Functional Group 

 

  1.  
0 Kudos