Users not able to add, edit, or delete | ArcGIS Portal 10.3.1 with Collector App Collector 17.0.2, build 1028

893
1
08-24-2017 07:34 AM
JordanMiller4
Occasional Contributor III

I'm having an issue allowing users within our organization to add, edit, and delete features from our published maps on Collector. We used layers from our Enterprise Geodatabase 10.3.1. I've included the following images showing our published settings from ArcGIS Desktop and Portal . Collector and Portal users are not given that editing option.

Current Software:

ArcGIS Desktop 10.3.1

ArcGIS Portal 10.3.1 

Enterprise Geodatabase 10.3.1 

Current App:

Collector 17.0.2, build 1028

 

Publishing a service:

Image 1 - 3 shows the settings that I used to publish our map service.

-------------------------------------------------

Created a new Portal's user permission

Organization --> Roles --> Create Role: See Portal user roles setting.png

0 Kudos
1 Reply
MicahBabinski
Regular Contributor

Hello Jordan,

What SDE-level permissions have been applied to the datasets you want your Operators to be able to edit? If you are connected to that SDE geodatabase using operating system authentication you will need to grant SDE editing permissions to your ArcGIS Server account.

Just to help diagnose - is your data versioned?

Finally, it looks like you've got a lot of layers in your ArcMap table of contents. It won't necessarily cause an issue - but do all of those layers need to be editable by your Operators? If not I would remove them - it will reduce the complexity and may help isolate the issue.

Micah

0 Kudos