Trouble Generating Portal Tokens

499
0
02-03-2023 08:40 AM
ZachBodenner
MVP Regular Contributor

Hello,

We've been having some issues lately with a few third-party applications that we believe are tracing back to issues generating portal tokens. We're doing some manual testing using the generateToken URL of our portal (https://<domain>/portal/sharing/rest/generateToken) and getting results that seem odd (at least to me)

So we have Enterprise 10.8.1, installed on a single machine with web adaptors installed on a server in the DMZ. when I go to the above link on my local machine I'm able to enter credentials for myself, other users, the third-party tester, etc and successfully generate a token. The third-party tester attempted to use their credentials while on a virtual machine and could not generate a token. I tried to replicate their work flow and I also could not generate the token from the VM. I've since tried multiple combos of information (different username/passwords, client choices) on many different VMs, all with no success.

I've also created a built-in Portal user (all other users coming from Active Directory), and got the same results, success on local machine, errors on virtual machines. I've also tried on other devices (tablet, phone) and couldn't get the token there either. 

Now in a separate third-party software, trying to create a connection to our Enterprise Portal that requires importing an Open API, I also get a generic error:

ZachBodenner_0-1675442256219.png

 

So far this seems to be affecting only third-party apps that attempt to get data or run processes against services on our ArcGIS Server. It also is a relatively recent problem - both of the above mentioned third-party apps have had no issues until 2ish months ago. Looking for any input on what could be the issue, thanks!

0 Kudos
0 Replies