The Date field in GIS Portal is not displaying accurately.

332
2
03-31-2020 12:41 PM
ThomasOlson
New Contributor II

We use a default Install Date of 1/1/2019 (for example).  We don't know the exact install so we generalize it.  

When I click on the polyline in GIS Portal - Web Application the date shows 12/31/2018.  

Why is the date not matching up?

I changed the Install Date to 1/2/2019 and the Pop-Up in GIS Portal - Web Application showed 1/1/2019.

The Date is always 1 day behind.

0 Kudos
2 Replies
KenBuja
MVP Honored Contributor

When you publish the data, you have set its time zone. From the documentation:

Coordinated Universal Time (abbreviated UTC) is nearly equivalent to the current time at Earth's prime meridian (zero degrees longitude), located near Greenwich, England. UTC is a more precise version of GMT (Greenwich Mean Time). When you publish feature layers containing date fields from files, ArcGIS Pro, or an ArcGIS Desktop app, specify whether the date values are in the local time zone or in UTC time. If the date fields contain local time zone information, you must specify this when you publish the layer. This enables the publishing process to transform the local time data into UTC for storage in the database. The time values will then appear correctly in your local time when you view them in ArcGIS Online. However, the data is converted to and stored in UTC time in the database. Dates are converted to UTC because the physical location of the server hosting your data and the people viewing the maps that contain your data can be anywhere in the world. Storing the time in UTC allows ArcGIS Online to transform the data to the correct local time zone regardless of the location of the server or the viewer of the application.

JamesShively
New Contributor III

".When you publish feature layers containing date fields from files, ArcGIS Pro, or an ArcGIS Desktop app, specify whether the date values are in the local time zone or in UTC time."

Where do you make the selection to specify your data as local time zone or in UTC time?  I am using ArcGIS Pro 2.6.2, 2.7.2 and 2.8.2 on various computers and don't have this option on any version. Is this option only when the data is published from within ArcGIS Pro or is it available when you add items within portal?

0 Kudos