Symbology to representation, reps do not have any rotation

1988
4
04-19-2011 12:01 PM
WesChristensen1
New Contributor III
Using Arc 10,
When I go to turn the symbology of a point feature class that is rotated by a field attribute into a representation, the new representations are all vertical with no rotation.  I tried the +180 or turing everything negative workaround in 9.3 but that does nothing.  I need to be able to define the representations rotation by its field attribute, what I am doing wrong!!
Tags (2)
0 Kudos
4 Replies
AnnaSchwabedal
Esri Contributor
Using Arc 10, 
When I go to turn the symbology of a point feature class that is rotated by a field attribute into a representation, the new representations are all vertical with no rotation. I tried the +180 or turing everything negative workaround in 9.3 but that does nothing. I need to be able to define the representations rotation by its field attribute, what I am doing wrong!!


Hi there,

with Field Mapping you can rotate your representation point symbols by a field attribute. The field has to be a Double or Float and my guess is that your rotation field is a Short Integer...
So:
- add a new attribute field (Double or Float) to your feature class
- use the Field calculator to get your values to the right field
- in the properties of your representations point symbols switch to Field Mapping View and define for Rotation the needed attribute field.

Cheers,
Anna
________________
Anna Schwabedal
Produktmarketing
ESRI Germany
0 Kudos
WesChristensen1
New Contributor III
Sweet, thanks!!!
0 Kudos
DWR_BuckEhler
New Contributor III
Hi Anna,
I am having the same problem. But I do not know how to get to the point symbol representation properties and switch to the "Field Mapping View." Could you please be more specific about where to define the attribute field for rotating point symbol representations. My rotation field is already set to a double.

Thanks,
Buck E.
0 Kudos
JulianWard
New Contributor
Hi Anna,
I am having the same problem. But I do not know how to get to the point symbol representation properties and switch to the "Field Mapping View." Could you please be more specific about where to define the attribute field for rotating point symbol representations. My rotation field is already set to a double.

Thanks,
Buck E.


Buck,

I think you'll find the option your looking for if you go into the Layer Properties window for the Representation layer (just like you would for any other layer), select the Symbology tab.  If you have a representation set, you should have the 'Representations' option selected in the 'Show' area, the 'Rules' in the next section of the window, and then the 'Markers' section.

At the bottom of the 'Marker' section is the symbol for a geodatabase (last symbol before the arrow button), click on this should bring up <Override Field>'s for each of the marker properties.  Select your rotation field next to the 'Angle' option, hit apply and all should be good, however note that the rotation angle will be Arithmetic, not Geographic, so it might rotate them differently to your points.  To fix you'll have to recalculate your angles (this is the stage I'm up to atm) to get it right.

Hopefully this helps you out,

Cheers,

Jules.
0 Kudos