Root node is not available for layer - open published scene

1970
5
04-26-2017 02:19 PM
JayH
by
New Contributor III

Hi, 

I published some 3D scenes through the Portal for ArcGIS, and all the time I have errors saying 'Root node is not available for layer'.

I saw the help saying it is due to generating caches, but I still have the same errors from the scene created even last week.

Troubleshoot scenes and 3D data—Portal for ArcGIS | ArcGIS Enterprise 

Is any setting might be wrong? I have ArcGIS server for my federated/ host server for my Portal.

I am pretty new in Portal.. any help would be great. 

Regards,

Tags (3)
0 Kudos
5 Replies
DanielleLoring1
New Contributor

Hey Jay! I have the same question and so far have not been able to resolve the issue. By any chance did you figure out what the issue is? Thanks!

0 Kudos
MahmoudElsayed_Ahmed
New Contributor

Simply you must install ArcGIS Data Store to solve this issue and to be able to access the ./nodes/root URL

0 Kudos
SimonJackson
Occasional Contributor III

Im also getting the same issue with a 10.5.1 base deployment.

Can publish a scene from Pro fine and the jobs looks like it completes with a green tick.

But then when I open it in the Scene Viewer = fails to loads all of the layers from the original scene "Scene service is missing root node."

I have also tried throwing a simple scene package into My Content, but this also gives me the same error in the scene viewer.

0 Kudos
Luiz_AmadeuCoutinho
Occasional Contributor III

The same problem here. Any solution? Portal and Federate Server.

0 Kudos
JeffreySutherland
Esri Contributor

Hi Jay,

What operating system is your ArcGIS Enterprise deployed on - specifically the machine running ArcGIS Server?

If your ArcGIS Server site is installed on Windows Server 2016 and is set as the hosting server,  you are required to enable SSL 3.0 in the Internet Explorer options for that server machine (this option is disabled by default). If your ArcGIS Server site has multiple nodes, you must enable this option on each server machine. This will allow hosted scene layer caches to be built. Note, depending on the size of the data being published, the cache building process may take some time.

I noticed you have already seen the troubleshooting steps for scenes and 3D data. If you are operating on Windows 2016, please try the steps listed in this Tech Support Article.

Thanks,

Jeff

0 Kudos