Removing thousand seperator in webmap

4666
8
Jump to solution
06-01-2015 12:58 AM
ArnoldKuilman
Occasional Contributor

Does anyone know how to remove a thousand separator from the legend in a webmap?

I have a legend with years, and want to remove the thousand separator:

so, away with the comma's in above legend..

Tags (2)
0 Kudos
1 Solution

Accepted Solutions
JayantaPoddar
MVP Esteemed Contributor

In the Web-Map, go to the Sub-layer (Click the drop-down) > Change Style > Select Drawing Style > Click "Options". Change the labels.

This will get reflected in the legend.



Think Location

View solution in original post

8 Replies
JayantaPoddar
MVP Esteemed Contributor

Hi Arnold,

Did you publish an MXD to map service for the creation of WebMap. If yes, then open the MXD file. Go to Layer properties > Symbology. Change the labels of symbology to exclude the comma separators.



Think Location
0 Kudos
ArnoldKuilman
Occasional Contributor

Unfortunately the labels in the MXD show different formatting from the webmap. I don't have an option to exclude the comma separators in the MXD/layer symbology.

0 Kudos
JayantaPoddar
MVP Esteemed Contributor

How about enabling time on the layer, and then  overwrite the service?

If that doesn't help, maybe someone can help you configuring the legend widget.



Think Location
0 Kudos
JayantaPoddar
MVP Esteemed Contributor

In the Web-Map, go to the Sub-layer (Click the drop-down) > Configure Pop-up > Configure Attributes. Slect the Field. Change the format. Uncheck "Use 1000 separator".



Think Location
ArnoldKuilman
Occasional Contributor

Tried that, nicely removes the separator from the pop-up, but not from the legend...:

I will try formatting the field to data, but that is limiting my classification options...

0 Kudos
JayantaPoddar
MVP Esteemed Contributor

In the Web-Map, go to the Sub-layer (Click the drop-down) > Change Style > Select Drawing Style > Click "Options". Change the labels.

This will get reflected in the legend.



Think Location
ArnoldKuilman
Occasional Contributor

haha, I feel ashamed...

I knew it was easy, but forgot to click on the labels itself.. but thnx:

JayantaPoddar
MVP Esteemed Contributor

Thanks to your question, I explored the web-map configurations. I used to ignore these things.

Cheers!!!



Think Location
0 Kudos