Re-publishing map service

493
4
05-21-2021 10:50 AM
ChadTheismann
New Contributor II

I am a Enterprise neophyte and inherited some web mapping applications.  I am attempting to update some edits to shapefiles that appear in my WebApps.  When I the follow the notes my predecessor left to update a shapefile, the updated layers are not drawing consistently in the WebApp.   I have attempted updates with 3 shapefiles.  In 1 of the 3 cases, the layer does not draw in my WebApp.  All the updates were done with a copy that was renamed to the original.  When I try to revert to the original file, the original does not draw either.  I need some help with troubleshooting.  I have restarted the Web service.  Anyone else experienced similar behavior?  Thank you.

 

 

0 Kudos
4 Replies
DavidPike
MVP Frequent Contributor

Has the schema changed? That would cause a mismatch between stuff such as the fields symbology/labelling is based on, and popups etc.  The best bet would probably be to re-add the feature to the offending WebMaps and re-configure as needed.

0 Kudos
RandyKreuziger1
New Contributor III

Chad, could you post a copy of the notes your predecessor left or the workflow that you are using?

0 Kudos
ChadTheismann
New Contributor II

My lack of skills are shining through....after re-examining paths, an elegant solution was discovered- the WebApp was pointing to different file lol.  That brings me to my add on question- is there a simple way to obtain a list of all files accessed by a WebApp and their file paths?  Thank you.

0 Kudos
DavidPike
MVP Frequent Contributor

It depends on if the data is hosted or not, if not, the path back to the data source is more involved.

if hosted, it should be a  case of accessing the layers within the WebMap Working with web maps and web scenes | ArcGIS for Developers

 

0 Kudos