"The web adaptor configuration URL has to be accessed from the machine hosting the web adaptor."

05-28-2015 09:55 AM
New Contributor

I am configuring the adaptor on the machine.  I have tried to configure it from the web page and the command line.  What do I now?

I'm installing a new ArcGIS Portal on an Azure VM (Windows Server 2012 R2) .  I am stuck at the step to configure the web adaptor to connect to the Portal.  The AGS is online on port 6080. The Portal is online on port 7443. I set up a self-signed SSL certificate.   I have tested the SSL and verified it does serve web pages. 

Since this is an Azure VM it has two IP addresses, one is internal the other is external.  When I ping the fully qualified computer name I get the IP of the external E.G. ping mycomputername.mydomainname.net returns the external IP.

8 Replies
New Contributor

I have the same issue. I have installed web adaptor in a Tomcat 8 server. I configured it to use port 80 and I enabled SSL, but when I want to configure the web adaptor, there is a message saying "The web adaptor configuration URL has to be accessed from the machine hosting the web adaptor". Any idea why is this happening?

Thanks in advance

0 Kudos
MVP Frequent Contributor

Hi Brian,

You have to remote desktop to the virtual machine where the web adaptor software is installed.

Then use the fully qualified name when you go through the web adaptor dialog.

Also, I'm pretty sure Portal for ArcGIS requires at least a domain signed SSL. Self-signed is not allowed.

And Portal only supports a single web adaptor unlike ArcGIS Server where you can setup one for SSL and one not.


New Contributor

Hi Bill,

i have exactly the same problem as Brian, using ArcGIS Server and Portal v10.2.2 with Tomcat 7.0.77 and a Hyper-V VM with Windows Server 2012.

What exactly do you mean with "You have to remote desktop to the virtual machine where the web adaptor software is installed."?

0 Kudos
Occasional Contributor III

Felix:  to access the web adaptor (WA) configuration software, you have to be logged onto the server on which the WA is actually installed.   If the server is a Windows OS, then can you use Remote Desktop (RD) that is part of Windows to log onto the server or if the server is physical, you can either RD to it or log on directly from an attached keyboard and monitor.

To RD to the server (or any PC for that matter)  you either need to know the server's IP or name on the network and of course have access to that network. 

If the server is Linux based and a VM, then you'll need a terminal program (I'd assume one that allows a GUI interface but I haven't worked with Esri on Linux so don't know what the remote access requirements would be (X windows compliant or ?)

Hope this helps.

New Contributor

Hey Paul,

thank you, but connecting via Remote Desktop to my VM didn't solve my issue.

For configuring the web adaptor i have used a self signed SSL certificate, because in my company it is rather difficult to get an enterprise certificate. Are there any workarounds that i can try out for the Portal setup with a self signed certificate (e.g. a specific tomcat version etc.? It is only for testing purposes.

Thanks again for helping.

Edit: I finally managed to solve the problem by using the JRE 7 together with Tomcat 7 instead of 8.

0 Kudos
New Contributor II

Also if running your web adaptor on Windows check your internet explorer settings and make sure you do not have a proxy server configured (internet options, connections, lan settings, proxy). depending on how your servers are configured on your network this could be causing a loopback that convinces the web adaptor that you are not connecting from the system where the web adapter is installed, even if you are.

New Contributor III

Thank You. the solution works to me. Similiar issue for ArcGIS Server upgrade - removing proxy server solved the issue. 

0 Kudos
Occasional Contributor II

Dear ESRI --

It's 2017 now, and two years have gone by since this problem was reported, and containerization is now a common practice. The problem still exists in 10.5.1; you still need to fix this.

Containers and headless servers don't have "remote desktops". It's possible to install desktop software on a Linux server but not desirable. With containers, (like Docker) it is really not practical.

I am currently battling with the configurewebadaptor.sh script, it would be nice to have a functional web interface to fall back on if I cannot get that to work.