"Source" button missing from Configure Pop-Ups in Map Viewer

1860
10
Jump to solution
03-21-2022 11:58 AM
acharko
New Contributor III

I am trying to modify the HTML of a text element that I've added to a pop up in Map Viewer (not map viewer classic). In ArcGIS Online, there is a "Source" button. In Enterprise Portal, this source button appears to be missing. I'm adding some screenshots:

1. ArcGIS Online:

acharko_0-1647888995599.png

 

 

Portal (and the HTML never renders): 

acharko_1-1647889029380.png

 

 

0 Kudos
1 Solution

Accepted Solutions
JasonCyphers
Occasional Contributor III

If you type out the text you want to embed the link to, then highlight it (or highlight the attribute field) and click on the hyperlink icon (circled below) you can paste the URL in the pop-up:

JasonCyphers_0-1647953289427.png

 

View solution in original post

0 Kudos
10 Replies
JasonCyphers
Occasional Contributor III

May have something to do with the fact it's still in Beta for Enterprise, and/or the version or Portal you're using?

I'm utilizing Portal 10.8, and there's functionality in AGOL's Map Viewer that I don't have in Portal's Map Viewer (Beta), but I see where it's available in Portal 10.9.

acharko
New Contributor III

Thank you! That's probably it. I'm trying to create a URL from various fields, but when I create it as a simple field/expression, it does not return as a URL. I was trying to use the expression in an "add text element" to the pop up and making use of the HTML button to do the <a href> tag. Any ideas on how to create a URL field if the source button isn't available in portal/enterprise?

0 Kudos
JasonCyphers
Occasional Contributor III

If you type out the text you want to embed the link to, then highlight it (or highlight the attribute field) and click on the hyperlink icon (circled below) you can paste the URL in the pop-up:

JasonCyphers_0-1647953289427.png

 

0 Kudos
acharko
New Contributor III

Thank you! That worked. I just added my expression into the URL and in the pop up, gave it a generic name.

Thank you for your help!

0 Kudos
VanessaSimps
Occasional Contributor III

While you are right that you can add a URL link, there doesn't appear  a "source" (html editor) button ??? If you need to customize the HTML for your pop-up, how are you supposed to do that when creating a web map in Portal?

VanessaSimps
Occasional Contributor III

I have been having an issue where my URL for the hyperlink keeps disappearing after I configure it in my pop-up. Has anyone else had this issue? I have tried to fix this by using both the link icon button to format the hyperlink and writing it out in the HTML. Sometimes it will stick, other times it will just clear out everything.

This has happened in several of my maps and with others in my group when using the new map viewer. 

0 Kudos
edmeehan
New Contributor II

Hi, I am trying to do the same thing: create custom HTML pop-ups in the new Map Viewer and Experience Builder in Portal 10.9.1. However, I am also am not seeing the "Source" button. Is this missing in 10.9.1? Thanks!

JasonCyphers
Occasional Contributor III

If I remember correctly, I've done it by opening a map in Map Viewer Classic, adding the feature(s), then editing the html there, via the source button. Switch back to the regular view, copy it, then open the newer map viewer and paste it there  Alternatively, you can edit the pop-up in AGOL Assistant.

0 Kudos
VanessaSimps
Occasional Contributor III

I was just playing with this again- looks like if you use the Visualization tab in the feature layer's detail page, you can get to the source button in the icon and save it out as a new layer, rather than doing the work in the Map Viewer. 

0 Kudos