Publishing feature layer (hosted) in ArcGIS Portal not working (due to invalid token?)

304
1
08-04-2019 11:18 PM
AsparuhKamburov
New Contributor

I have an ArcGIS Portal 10.7.1 and a federated ArcGIS Server 10.7.1 with configured hosting server. Since the first installation I have difficulties to maintain a stable and constant publishing of feature layer (hosted) from within the Portal interface (e.g. Add Content/From my computer/Shapefile). I have identified the following common cases when the problem occurs:

  • After server machine (Windows Server 2016) restart (e.g. after OS updates);
  • After changes in the Organization members (e.g. password changes, disabling members, changing item ownership);
  • After Windows Firewall restarts.

ONe of the last cases was for some reason the initial administrator account couldn't publish hosted layers, however the other members (publisher role) could. I created a new admin portal member, which had no problems to publish hosted layers.

This morning I found my server machine restarted (maybe due to power fault or something other unexpected). As I expected, now I cannot publish hosted layers again. All the times so far it is always the same type of error:

The ultimate error which I occur every time

I use an administrator OS account with access to the ArcGIS installation folders, service folders (e.g. arcgisserver; arcgisportal). Strangely, but I can publish from within ArcGIS Pro without problems - either as Web Maps or as Web Layers - copied or referenced.

I also tried to validate the Server within Portal. It give a green tick (validated), however I explored the debug logs in Server, and the following appears:

Is this a problem of some TOKEN that vanishes after changes in the system?

Is there a procedure, e.g. command line utility program or something else that can help restart this service. Or maybe some lock files are written somewhere and they forbid access to the GPServer after any change in the OS settings. I tried to restart Portal, Server and DataStore services in Windows Server, but the problem persists. I really cannot figure out why this service crashes in various cases.

Thank you for your help!

Asparuh Kamburov

0 Kudos
1 Reply
DanielBrumm1
New Contributor

I realize this post is a couple years old but did you ever figure this out? I have issues with my hosted feature layers anytime we restart one of our hosts. I noticed that in the logs I see a lot of invalid token error message right after the reboot happens. 

0 Kudos