Publishing exception: hostname doesn't match

1501
3
07-19-2018 10:28 AM
DianeBird
New Contributor III

I have recently set up an Enterprise portal and have "successfully published"  3D scene layers from ArcPro 2.2;  however, in the portal content, it only lists a service definition.  When I try to publish from the portal, I receive the error:

       "Publish exception  'Exception: hostname in certificate didn't match: !=OR' "

What can I do to resolve this issue?

0 Kudos
3 Replies
JonathanQuinn
Esri Frequent Contributor

You likely federated Portal and server using an incorrect admin URL. Do you recall what URL you entered? If you go to the certificate assigned to that URL, does the hostname of the match the CN?

For example, in Chrome through the dev tools and security tab, you can check the CN of the certificate, (Issued to information). I'll assume you don't have any Subject Alternative Names, so the Issued To hostname should match the hostname you used during federation for the admin URL.

0 Kudos
DianeBird
New Contributor III

It looks like the portal is picking up the Self-signed certificate with the machine name instead of the 3rd party issued certificate with the domain name.

0 Kudos
JonathanQuinn
Esri Frequent Contributor

If you have an existing certificate to use for 6443, (if you federated using https://server.domain.com:6443/arcgis as the admin URL), then you'll need to follow the instructions in the link below to tell Server to use the new certificate:

Configuring HTTPS using an existing certificate—ArcGIS Server Administration (Windows) | ArcGIS Ente... 

0 Kudos