Portal Map Service Layers refusing to draw

802
5
12-04-2020 09:59 AM
Mark_Hotz
Occasional Contributor II

I created a map service for Portal 10.8.1  (using ArcGIS Pro  2.6.3 from which I published).  This map service contains 5 frequently used map layers, and they all draw to the screen exactly as expected after publishing.  However, the next day two of these map layers always refuse to appear, whereas the other 3 are usually fine.  If I republish the map service these reluctant layers do reappear, but the next day it's back to the 2 missing layers, which is most frustrating.

The only difference between these 2 map layers and the other 3 is that the popups have been customized (as opposed to using the default database tables/attributes), because there is no relevant data in these areas (just a name of what they represent).

Has anyone ever encountered this issue before?  I have tried clearing the browser's cache, but this did not fix the problem.  Surely I don't have to publish this one map service every day, correct?

Suggestions?

Tags (2)
0 Kudos
5 Replies
NoahKrach
Esri Contributor

Hello,

After this behavior occurs, do you see anything in the Portal or Server logs in regard to this map service? I would also be curious if there are any errors in the network traffic when trying to load in the 2 layers that are not appearing.

0 Kudos
Mark_Hotz
Occasional Contributor II

Noah:

I will have to check this the next time I'm reviewing my web maps (still on vacation), but this is a pretty good troubleshooting suggestion, and definitely worth exploring.

Thanks

0 Kudos
SamLibby
Esri Contributor

One idea would be adding each individual layer to a web map as a feature layer (/0, /1, /2 etc.) and seeing if the features display reliably. When you say the popups have been customized, what do you mean by that? That you configured them and saved them in the web map after publishing the service?

There are two relevant levels of popup configurations:

1. the web map's configuration (by saving the popup config of a specific web map)

2. the configuration of the portal item that represents the federated service (by selecting "save layer" on the layer once configured in a webmap).

 

 

0 Kudos
Mark_Hotz
Occasional Contributor II

Sam:

Thanks for the response...most appreciated.  I haven't yet tried to publish each of these 5 layers individually, but I do have one map that only has the problem layer as a part of that map's service.  Whenever the problem starts it seems to do it in all of the map services though.

The odd thing though is that when I republish I don't have to change anything in these map services...they all return as intended (i.e. even though I get the warning when overwriting a map service that my popups will be affected, nothing ever seems to happen to them after republishing).  It's either something new in 10.8.1, or this is very abnormal behavior...I don't know yet.

What I mean by customized popup is that for a feature class that has no significant database attributes I simply customize the information in Portal so when the user does indeed click on the polygon they at least see something that is more meaningful than OBJECT ID, SHAPE, etc.

Mark_Hotz_0-1609345226335.png  

Mark_Hotz_1-1609345514310.png

 So in this case, when the user clicks on this area they will see something meaningful (I just find it easier to do this than to update fields in our geodatabase):

Mark_Hotz_2-1609345675767.png

This is also the layer that is causing me grief.  Sometimes it shows up (like it does now), and other times it's the only layer of the 5 in this map service that doesn't show up.  But if it's the customized popup that is now causing the problem, then updating the attributes in the feature class would be an option.  I would first like to determine what is causing this problem though 8).

 

0 Kudos
HollyTorpey_LSA
New Contributor III

@Mark_Hotz Did you ever get this figured out? I am having a similar problem with a feature service published from ArcGIS Pro to Portal containing multiple layers. The top layer draws fine but the others don't draw at all and show no records in their tables (though I swear they were drawing fine yesterday, the day I originally published them). I have tried publishing them as individual single-layer feature services with the same result (the same layers that wouldn't draw still don't draw). I get no errors during the publishing process. I also tried publishing them as a vector tile service with the exact same result. I published dozens of other layers yesterday but the problem only exists with this group.

- Holly
0 Kudos