Need help changing Portal for ArcGIS Account

1629
7
Jump to solution
03-22-2019 01:34 PM
ReidWebb
New Contributor III

Hello, all! I am trying to use the configureserviceaccount utility located in the tools directory to change the Portal for ArcGIS Account for Portal 10.5.1. 

The service account is currently the default arcgis local account. I am trying to change it to an Active Directory service account. I have verified this domain account is enabled and active by logging into our network with it. So I'm pretty sure the service account and password are good.

Using the help, I found that the tool to perform this task is the configureserviceaccount utility, a command line tool. In the command prompt window, I navigate to the C:\Program Files\ArcGIS\Portal\tools\ConfigUtility\ folder and attempt to execute the following command:

configureserviceaccount --username [mydomain\username] --password [mypassword] --writeconfig [myfolder\filename]

Here are the errors I get when I run the tool:

Failed to determine the state for service: Portal for ArcGIS.

Failed in setting directory permissions for: C:\Program Files\ArcGIS\Portal\ 

plus seven more errors like the one above, but for 7 of the subfolders under C:\Program Files\ArcGIS\Portal\ 

Any assistance would be most appreciated. Thank you!

1 Solution

Accepted Solutions
DanielUrbach
Occasional Contributor II

Hello Reid,

Are you running the command prompt as an administrator?  If you right-click on the command prompt icon or button on the task bar and select "Run as Administrator", then try the command again, does that resolve the issue?

-Danny

View solution in original post

7 Replies
DanielUrbach
Occasional Contributor II

Hello Reid,

Are you running the command prompt as an administrator?  If you right-click on the command prompt icon or button on the task bar and select "Run as Administrator", then try the command again, does that resolve the issue?

-Danny

ReidWebb
New Contributor III

Daniel, your solution worked! I'm so glad you responded because I would never have thought of this solution. I am logged into the system as an admin, why would I have to Run As Administrator?!

Thanks again!

0 Kudos
ReidWebb
New Contributor III

Please add your solution to the ESRI guide I was following for this task

http://enterprise.arcgis.com/en/portal/latest/install/windows/changing-the-portal-for-arcgis-account...

0 Kudos
saraswathiemani2
New Contributor III

Hi, I am running as the administrator for new install of ArcgisPortal 11.0 . But I  get the error: 

saraswathiemani2_0-1670871270527.png

I checked the Portal folder but could not find the customizations folder. I have 10.8 version of portal  on different server, where I could find the customizations folder. Any reason why I cannot find the folder in 11.0?

saraswathiemani2_2-1670871619179.png

 

BillFox
MVP Frequent Contributor

Did esri send you the missing config.js file for 11.1?

0 Kudos
saraswathiemani2
New Contributor III

Nope. I created a customizations folder and the utility ran successfully and changed username. 

Todd_Metzler
Occasional Contributor III

Same problem Enterprise version 11.1. Can't determine state of portal service error.  Post upgrade from 11.0 to 11.1 on Windows server 2019 standard OS.  I am machine admin.  I envoked command prompt as administrator.  Now I broke the Portal by changing the run as account from local account to domain account in the Windows services and manually setting the portal folder permissions for the domain account.  The hosting server is on the same machine with run as set to domain account and is OK.  What are my recovery options?