Navigating within portal changes url from https to http

2483
4
Jump to solution
03-29-2016 05:20 AM
CollinJohnston
Occasional Contributor III

We are just getting setup with Portal and I'm having some difficulties. I'm guessing my problem is relating to how I have IIS or the self signed cert. setup. I'm kind of new with IIS so this could be very simple.

I recognize that using a self signed cert is not best practice for production, but this is just our test env and I am simply trying to get to a point where I can really start playing around with portal, deploying web apps to our local server using our AGS map services.

However, I am seeing behavior where I navigate to the my content page https://<webservername>/portal/home/content.html without an issue. No cert warning etc. Then when I click any of the navigation links within Portal, the web address defaults back to http. so the my organization url looks like http://<webservername>/portal/home/organization.html

I can fix it by simply adding the "s" after http, to keep moving along, but clearly there is some setting I'm missing. Anyone have an idea of what I'm missing?

0 Kudos
1 Solution

Accepted Solutions
PaulDavidson1
Regular Contributor

Try changing the security setting to https only.

-Paul Davidson

View solution in original post

4 Replies
PaulDavidson1
Regular Contributor

Try changing the security setting to https only.

-Paul Davidson

CollinJohnston
Occasional Contributor III

And a big thank you Sir. That was fairly easy to fix... I'm sure I'll have more posts as I stand this thing up on beta.

Navigate to Portal > My Organization Page > Edit Settings > Security > Check "allow access to the portal through SSL only" un-check "allow anonymous access to your portal"

Seems to have fixed my problem.

Thanks, Paul - Cheers.

0 Kudos
PaulDavidson1
Regular Contributor

Good news!

I think that was my fix awhile back

I think you might have some trouble with self signed cert. I think you need CA or a domain one.

Also, if using IE, need to turn off compatibility mode.

There are a couple of longer threads (under Issues Closed) about this sort of thing on the Esri Chef Cookbook on GitHub. Worth the read.

-Paul Davidson

CollinJohnston
Occasional Contributor III

I agree with running into trouble with the Self Signed Cert. I think i'm already seeing some of these issues, but while I wait for IT to help me with a CA issued, this will get me into the app to see how much trouble I can cause...

Thank you for the IE tip and the other reference material. Greatly appreciated.

Thanks again Paul

Cheers -

0 Kudos