Maplex - Place one label per feature part (line)

3528
6
09-23-2011 08:14 AM
FletcherO_Brien
New Contributor
Using the Maplex Label Engine, I???m trying to limit each line segment to displaying its label only once. So far I???ve found no way to accomplish this. Does anyone have any suggestions?

Thanks!
Fletch
Tags (2)
0 Kudos
6 Replies
FletcherO_Brien
New Contributor
I think I�??ve already tried all the Conflict Resolution options. In my situation, the problem is that I�??m labeling trail segments with their respective distances. Because several of the trails are the same length (rounded to one decimal place), Maplex will display the distance value for only one of the trails on screen, leaving the other one(s) unlabeled. This isn�??t a problem for most of them, but it would be nice if every segment displayed its value, and then only once.
0 Kudos
FletcherO_Brien
New Contributor
I�??m very interested in what you make of this. Thanks for the interest.
0 Kudos
FletcherO_Brien
New Contributor
Great idea, thank you Eric! This never occurred to me. I will give it a shot as soon as I get time.

Fletch
0 Kudos
ChristyPrentice
New Contributor
What if you're features are indeed multi-part...for example a divided highway?  I am trying to label traffic volumes (which are not directionally split), and also can be the same from segment to segment.  When using Maplex I get a label placed for for each direction of travel (each part of the feature)...which is very misleading to the user.  The standard labeling engine has a great option of "one label per feature" but Maplex does not.  Unfortunately I need Maplex to make all the other labels look production quality.
0 Kudos
ChristyPrentice
New Contributor
Maplex in ArcGIS 10.1 has a new Label Density Tab: Uncheck the Connect features check box, then click the Multipart Option drop-down list and select one of the options�??One label per feature, One label per feature part, or One label per feature segment.

http://resources.arcgis.com/en/help/main/10.1/index.html#//00s800000074000000
0 Kudos
Thinley_JyamtshoWangdi
New Contributor II
Dear All,
I am using ArcView 10.0.
I have one point layer with numerous points to be labelled in one mxd. The following environments have been set.
label weight = high
feature weight = low
scale = automatic
label ranking = high.
checked = remove duplicate labels.

Now my idea is to label those point features but its not labeling despite checking the "label feature". where ever there is confusion for label to appear due to lack of space, i need labels to appear not crowded but may be few labels appearing. This is not happening.

Will appreciate if you could give some advises.
Thank you so much
Wangdi
0 Kudos