Layers Only Visible In Web Map If User Is Administrator

01-22-2020 06:09 AM
Occasional Contributor II

I recently created a web app for one of my users, but the layers won't load unless the user viewing the app is an Administrator.  The app is hosted in an ArcGIS Enterprise Portal environment running 10.7.

The layers, map, and app are shared to a group to which the user has been added.  The user account can view all the items in the group, but when trying to add any of the feature layers to a map, the layers won't load there either.

The user account is an Enterprise account federated with Active Directory, and I had initially set her account role as Data Editor.  I tested the web app with two user accounts that are Administrators and it worked normally.  I tried gradually stepping up my end-user's account until it finally worked setting her as an Administrator.

Does anyone know what might cause this, or if there's a work around?


Tags (2)
0 Kudos
1 Reply
New Contributor

We're having a very similar issue, did you find a solution to this? 

0 Kudos