Layer cannot add to map in protal

4381
5
08-31-2016 10:03 PM
PrasadG
New Contributor II

Hi...

      I have problem with adding layer to map in portal,  I publish the Feature Service from arcpro to portal it was successfully published to portal but when feature Service open with map in portal it show error "The Layer cannot be added to the map".

portal was federate with server and data store also configure......if any solution please send.....

Thank you ....

Tags (1)
0 Kudos
5 Replies
JayantaPoddar
MVP Esteemed Contributor

I hope the feature service and the associated map service are visible in My Contents of Portal for ArcGIS. Try adding the associated Map Service to the Map Viewer. Is it still returning the error message?

Is the issue linked to a particular feature service or all services? What happens when you publish a Map Service (without Feature Access)?

Could you also tell us bout the versions of ArcGIS Pro, Server and Portal



Think Location
PrasadG
New Contributor II

Thanks for replay Jayanta..we are using 

ArcGIS Pro version 1.1
ArcPortal 10.3.1
ArcGIS Server 10.3.1

0 Kudos
PrasadG
New Contributor II

I was published  the web map or web layer from arcgis pro to portal. It was publish successfully and appear at my content but when try to open that service it show error like "The Layer can't added to map" it happen to all services which  was published from arcpro. 

0 Kudos
DerekLaw
Esri Community Moderator

Hi Prasad,

> it happen to all services which  was published from arcpro

I suggest you double-check and verify that you configured your hosting server with Portal for ArcGIS correctly.

Configure a hosting server—Portal for ArcGIS (10.3 and 10.3.1) | ArcGIS for Server 

Another thing to try, have you installed the ArcGIS Pro 1.1 patch?

ArcGIS Pro 1.1 Patch 1 (1.1.1) Now Available | ArcGIS Blog 

Or better yet, can you upgrade ArcGIS Pro to a more recent release, like 1.2?

Hope this helps,

DerekLaw
Esri Community Moderator

Hi Prasad,

I suspect something's not quite right with the hosted feature service you published to Portal.

Suggest you try to re-publish the hosted feature service to Portal?

And as Jayanta requested, please post the software versions you're using.

Hope this helps,