Is there a record limit on "Create Local Copy for Editing"?

04-29-2019 03:45 PM
New Contributor III

We have an Enterprise deployment and Running 10.6. Having an issue with editing more than 1,000 records at once.  Workflow currently involves:

1) Pulling feature service into ArcMap that is running in Portal

2) Create a Local Copy for Editing#

3) Joining an external data table to the local copy

4) Placing the local copy into edit mode

5) Updating a field of the local copy based on one of the join fields

6) Removing the join

7) Save and Stop editing local copy

😎 Sync local copy back up to Portal

Before Syncing, all edits appear to be fine in the local copy.  After syncing...all edits seem to work if there are less than 1,000 records in the local copy for editing.  All edits are ignored when local copy for editing exceeds 1,000 records.

Any known fixes or ways to increase this limitation would be greatly appreciated.  I am in need to edit ~6,000 records at one time.

0 Kudos
1 Reply
New Contributor III

-I was doing some trouble shooting and seeing if I could edit > 1000 records on a standard data set.  Using ~3,100 county centroids, everything worked fine with making local copy, updating field and the syncing with master.  So that threw out my max 1,000 record limit theory.

-Stepping up the complexity, I tried the county shapefile/polygons.  This not only failed but also crashed my system every time I attempted. So I took a guess and simplified the polygons by 1,000 meters.  With the simplified polygons the update process worked.

-Using the same approach to my 5,000 record data set, I simplified my polygons by 100 meters.  This did not impact the majority of the areas (Most of them were rectangles) but we did have about 1,000 circles.  I estimated that the circles probably had ~100 vertices, that were simplified to an octagon.  Net change per circle of 92 vertices x 1,000 instances simplified the entire dataset by ~92,000 vertices (All high level estimates).

-Once simplified, all the data editing/updates were working. I am assuming that there is not really a record “count” limit but some type of file size/complexity limit that can be handled with this workflow.

I hope this is helpful if someone else runs into the issue.

0 Kudos