Help with Enterprise 10.8.1 / Portal and GeoAnalytics

854
3
05-24-2021 09:52 AM
Labels (1)
jonathanharte
New Contributor III

Hi Guys, 

I'm stuck - I've exhausted myself looking at logs and I'm still no wiser.  

I have an enterprise installation , with Image Server, Raster Analaytics, GeoAnalytics, and GeoEvent roles. I have installed everything and my portal is working I can add items etc...  However I'm having issues - so starting with GeoAnalytics in portal al my jobs return esrijob failed <id**>.  So I have  test case to see whats goin on - I have created a point layer in my hosted datastore and using GeoAnlaytics in Portal within the webviewer I choose copy to datastore and choose spatiotemporal give it a name and run.  It returns with an error in the viewer after 30-40 seconds.  Looking in the hosting server admin / logs at debug leven I can see the progress, 

The hosted feature layer is created , and then deleted (I'm presuming because it cannot create the data in teh datastore).  I can see that there is and error with validaing the token from my hosting server

ARCGIS_PORTAL_TOKEN Authentication, Unable to validate token com.esri.arcgis.discovery.admin.security.AGSSecurityException: Server machine 'https://server@domain:7443/arcgis/sharing/rest/community/self' returned an error. 'Invalid token.'
then further down the log I see
SEVERE
Unable to connect to the manged egdb

 

My SpatioTemporal datastores validate , however I have one for GeoAnalytics and one for Geoevent ... and neither of them will update the ssl cert for the datstore .. when I run the updatesslcert bat  it return sucessful but still shows a certificate error when I access the https://<datastoremachine>:2443/arcgis/datastore  the other datastore machine retuns "Error encountered: Failed to generate a token for the user. Incorrect credentials provided."  then I run the updatesslcert bat ...

So I'm not sure if my issues stem from teh SSL certs on the datastore .. or something else.... 

Anybody have a clue what I'm doing wrong ? please

 

 

 

3 Replies
by Anonymous User
Not applicable

This is a long shot, but are all the servers set to the same time zone? That resolved some random issues for me when I was setting up our base Enterprise deployment. 

0 Kudos
jonathanharte
New Contributor III

Thanks for responding so quickly , its much appreciated...   sorry I clicked accepted solution by mistake .... But I will re-check what you have mentioned.  Because oddly enough I did spot this morning that   2 of the servers were on a Canadian timessone instead of London .. .I have since corrected this on the servers .. and can only assume this change is recoginised acroos the stack..  nothing has change error wise since I fixed the time issues ...    

I'll post if there is an update  .. and again thanks

 

0 Kudos
jonathanharte
New Contributor III

Hi Guys, 

No joy with the suggestion from Mary or time zones so far.. (thanks Mary)  

I have gone a bit further now and added wireshark to by geoanalytics server (limited abilities with wireshark ).  I have a filter on to see the https traffic tcp.port==443  and I can see the traffic between the enterprise hosting server, the geoanalytics server   all on internal IP's as you'd expect.  However its also trying to access and external IP - which it should not be doing as I have set internal proxy config - so it looks like the server is not using the proxy correctly ?   I've checked Tomcat and it has the proxy address  that i set in the /admin/system/properties along with the webcontext url ....  Is there something else i need to do to set the network proxy for internet access for Arcgis Server.....

so my log is showing me 

SEVERE : 

Job 'j45262e5283a24a0aa4026e3530f38ad7' for tool 'MergeLayers' failed: Connection timed out: connect.


DEBUG :

java.net.ConnectException: Connection timed out: connect ( )

 

DEBUG

REST call to
'https://MYPublicAddress/server/rest/admin/services/Hosted/Merge_Merge_Merge_CLIPPER_POLY_TESTPOLY2_C...' failed (reason=Connection timed out: connect) Connection timed out: connect

 


Any ideas  ?  please

 

Regards

Paulg

Tags (1)
0 Kudos