Failed to publish web layer from Pro 2.5, Portal 10.8 referencing registered enterprise database

12-10-2020 07:55 AM
Labels (2)
Occasional Contributor II

This is a new problem that emerged; I'm trying to publish a map image service to our Portal in Enterprise 10.8, with data as a reference to our registered enterprise geodatabase. There are no warning messages pre-publish, but it fails everything with a link to view the logs. On our server manager and Server Admin logs is see various errors related to the PublishTools.GPServer. No error reports related to this are in our server logs directly on the server machine. 

The Data Store is registered, and I even tried added a Portal item of the registered database in Server Manager to accommodate the 10.8 changes. 


server manager errors.JPG

2 Replies
by Anonymous User
Not applicable

Hi Ingrid,

Those are pretty generic publishing error messages, and we may have to do a bit more testing in order to get a better idea of what's happening. Here are some suggestions I would make:

  • Try publishing a service from a file geodatabase to ArcGIS Server
  • If you have a hosting server configured with your Portal site, try publishing the file geodatabase feature class as a hosted feature service 
  • If both of these work, then try exporting the feature class from the file geodatabase back into the enterprise geodatabase, and publish a new service

Additionally, you can set the log levels to Debug instead of Warning, which can provide much more descriptive error messages.

Hope this puts you on the right track.


0 Kudos
Occasional Contributor II

I ended up being able to publish from a different ArcGIS Pro project and separating a few of the datasets from one another into separate services. They all are stored in the same enterprise database, so I'm still not sure if it was a problem with the Pro project of the datasets. Thank you though.  

0 Kudos