Failed to get administrator token from Portal. Please verify that the Portal URL specified can be accessed successfully.

12-27-2017 07:51 PM
New Contributor

We upgraded from 10.4.1 to 10.5.1

Server first.  Then installed the 10.5.1 web adapter. 

I could not connect to the portal web site, and so I've beentrying to figure that out.  I decided based on reading a bunch of pieced together articles that I should maybe unregister the web adapter and re register it.  It WILL NOT work.  I've tried everything I can think of.

Failed to get administrator token from Portal. Please verify that the Portal URL specified can be accessed successfully.

I can access the portal by https://machinename:7443/arcgis/home

My portals name is not "arcgis"  So already this is confusing to me.  I have no idea also where these things are hosted from as there are no directories in my default web site, yet if I stop the site in iis I can no longer access it.  I guess its just arcgis magic. 

I pointed to this default web site when I installed the web adapter and gave it a portal name of xxxxhome. xxxxhome now exists as a sub application in my default website. When I am registering the web adapter I have been trying all sorts of combinations. The help tooltip only says to enter the URL of my portal and that it MUST be done using FQDN.  Thats fine because I have one configured I can use which is accessible both from the outside and local. I have also tried making a generic FQDN in my hosts file as another option. That also doesnt work.  The hint shows its using https...  :7443.   It doesn't indicate why its using 7443 of IF I need to do it the same way. But trying that it doesnt work either.  We had this set up and working before we upgraded.  When I set it up the first time I was able to use the made up "local" name from my hosts file just fine.  Now it doesnt work.  I can only assume this is all because of upgrading.  Very frustrating.  It took me way too much time in the fiest place just to get this thing running. Holy crap. Every single task I would do was error after error, google after google stumbling my way through.  It should not be so difficult. I know I'm being a little negative and I appologize. I'm just not sure what else to try short of uninstalling and reinstalling everything.  If I do that, how can I ensure I wont lose all my portal content?  Can anyone give me any more ideas?

Tags (1)
0 Kudos
4 Replies
New Contributor

I found the answer.  The error ESRI is giving is totally misleading. 

So, even though I unregistered the web adapter in the server manager, there was still a web adapter in place. This is why it would not work.  I went to  https://<machinename>:7443/arcgis/portaladmin   Found web adapters, and sure enough it was still in there with an option to unregister. So, I did that.  It took about 3 minutes with the spinning wheel in the browser before it refreshed and was gone. Then I went back to the server page to register the web adapter. I used the generic FQDN I made up just for this purpose from the first time I set up portal.  This was just something I threw in the hosts file. So, like this..  https://myportal.<machinename>.com:7443  as the url.  is pointing to localhost in my hosts file.   Then I used the PORTAL admin password, not the server admin password for credentials, and then it worked.  The re-registering also took about 3 minutes, so just wait for it. 

I hope this helps someone else. The key here is that if you unregister from the server admin, dont trust it worked until you check portal admin. 

This is the thread I finally found that helped me out. 

web adaptor not configuring portal 

After doing all that, I was able to access my portal from the outside again and everything works. All content is still there too.   I am still curious where this stuff is served from on my machine, but I'll just let that go for now.

New Contributor III

Very helpful.  Thank you Josh!

0 Kudos
Esri Contributor


I’m glad that you have resolved your issues. I wanted to add a few notes on upgrading to the thread.

When upgrading a deployment that has the full ArcGIS Enterprise stack of components (Portal for ArcGIS, ArcGIS Server, ArcGIS Data Store and the two web adaptors for Portal and Server), then it is important to upgrade the components together in a certain order.  


Here is a simple summary for upgrading a simple ArcGIS Enterprise deployment:

  1. Upgrade Portal for ArcGIS
  2. Uninstall Portal’s web adaptor (note the name of the web adaptor, as you will need to name the new installation the same)
  3. Install the Portal’s Web Adaptor, naming it the same as the previous web adaptor, and configure with your Portal site
  4. Upgrade any federated ArcGIS Server sites
  5. Uninstall Server’s Web Adaptor (note the name of the web adaptor, as you will need to name the new installation the same)
  6. Install the Server’s Web Adaptor, naming it the same as the previous web adaptor, and configure with your Server site
  7. Upgrade ArcGIS Data Store

Here are a few notes:

  • It is important to backup before you upgrade so that you can rollback to the original state if anything goes wrong.
  • Do not unfederate your ArcGIS Server sites before the upgrade.
  • Do not unregister the Portal and Server web adaptors before the upgrade.
  • It is important to maintain the Portal and Server web adaptor names because existing items in your Portal and Server likely reference that name.

I wanted to address your question:

I can access the portal by https://machinename:7443/arcgis/home

My portals name is not "arcgis"  So already this is confusing to me. 

By default, Portal for ArcGIS uses the HTTPS port 7443. You can access your Portal without going through the Web Adaptor using the url https://machinename:7443/arcgis/. However, it is recommended that the Portal site is accessed using the Web Adaptor url https://machinename/portalwebadaptorname/.


Here are some useful resources on this topic:

Hope this helps!

New Contributor II

The answers in this thread are super helpful.

In my case, I was setting up a 10.7.1 Base Deployment of Esri Enterprise (single machine) on AWS. I installed Server, then configured the web adaptor name as 'server'.  Then I intstalled Portal, and a second web adaptor named 'portal'. 

When I attempted to log into Portal from outside AWS, it threw me an error (400) of incorrect redirect URI.  It appeared to be sending me to /arcgis instead of /portal. I thought that somehow this was misconfigured. So I uninstalled the 'portal' web adaptor and then things got worse. I tried to re-install web adaptors for Portal again, taking great care to name theem appropriately, but kept getting the OP error above and couldn't complete configuration.  I checked IIS and there weren't any phantom adaptors. But I was unable to go to the https://aws-machinename/portal/portaladmin page (as noted in this thread above) and check for phantoms because it didn't exist my Portal had no configured web adaptor!

So, I had to uninstall the 'portal' web adaptor, then uninstall Portal application altogether. Restart the machine then reinstall Portal.  When I got to installing and configuring a new 'portal' web adaptor, I held my breath but it worked.

However, after configuration, it took me to the Enterprise page and I was able to log in as my portal admin user successfully.  The final check was to see if I could access our Portal from an outside location.  I could get to the Portal Home page, but when I attempted to log in, it gave me the same 400 redirect URI error!

I found a fix here, and followed scenario 1: Error: 400: Invalid redirect_uri 

Sure enough, the web app was configured as my local machine IP instead of the Fully Qualified Domain Name (FQDN) - even though I entered in our domain at configuration(!):  


so, to fix this, I kept the ec2amaz-machinename but updated the my-aws-machine-ip to our FQDN:


I hope this helps others, as I lost a solid 4-5 hours in figuring this out.   Thankful for these threads as well:

web adaptor not configuring portal 

Portal Configuration Error 

and also the Error: 400: Invalid redirect_uri  technical article.

0 Kudos