Error: Arcgis Portal Failed to update the data store connections file site Data store

2650
4
03-01-2019 07:15 AM
RoberthSanchez
New Contributor III

Hi, i have a problem when i try to put my federated server as hosting server on portal 10.5, this server is a arcgis server 10.5 with Data store, this error start to happen reinstalling ArcgIS Data store following the esri guide:

Uninstall ArcGIS Data Store—ArcGIS Data Store (Windows) Installation Guide | ArcGIS Enterprise 

and got this error: "The specified ArcGIS Server already has a managed data store" fixed with this guide:

Error: The specified ArcGIS Server already has a managed data store 

After applied this guide, i could configurate the data store without any error, then when i tried to configure the server as hosting server got this one:

"Failed to update the data store connections file site", seems like is a problem with the file dsconnection.lst, in data store logs i can't find any info and in the arcgis server log i got this:

<Msg time="2019-02-28T15:46:44,119" type="SEVERE" code="7415" source="Admin" process="37328" thread="14" methodName="" machine="xxxxxxxx" user="" elapsed="">Error al actualizar el archivo de conexiones al data store. Error al guardar el espacio de datos al archivo.</Msg>

 

i'll be gratefull if anyone can help me.

Thanks.

0 Kudos
4 Replies
LakshmananVenkatesan
Occasional Contributor

try this

a) take a back up copy of dsconnections.lst 

b) remove the line where  ID = 85D4l2.... in the file 

c) save and restart the DS ; try reconfiguring again.

0 Kudos
RoberthSanchez
New Contributor III

Thanks for your response Laskhmanan, already tried what you said, the ID=85D.. does not exist inside the dsconnection.lst file but following the guide:

Error: The specified ArcGIS Server already has a managed data store

Says that id could be found inside the Arcgis_dataStore_ds_ID > dataitem.json, then i remove the line with this id inside of my dsconnection file and restart the arcgis Data store service, but portal keeps showing the same message.

there is something else what can i try?

Thanks

0 Kudos
GaryChristensen
New Contributor III

Robert,  I'm getting the same type of error when attempting to validate a data store.  It was one that previously validated.  Did you resolve this error?  If so, please post your solution.  Thanks.

0 Kudos
RoberthSanchez
New Contributor III

Hi Gary, i found it by myself, is ArcGIS Server bug, the solution is first make a back up of dsconnection.lst, delete the original file and then go to arcgis server manager > data stores > Select ArcGIS_Data_Store (relational database) and click on check, that action will make the file dsconnection.lst again with correct configuration and all will work.

 

I hope this solution works for everybody.

Regards.