Delete Datastore Backup

09-25-2019 11:55 PM
New Contributor


    We have Datastore configured in HA with Primary and Standby servers (v10.5.1). It had replication issue and finally it was resolved and now Changing Roles(Active/Standby) are working fine. However, when I try to take backup of datastore, it fails for Relational with a following message:-

arcgis data store backup failed. error 'failed to create relational data store export file'

Where as it works fine for TileCache.

When I run listbackups.bat, it shows all the previous manual backups for Relational datastore which I ran with a status 'BackupRunning'(shown below):-

PS C:\Program Files\ArcGIS\DataStore\tools> .\listbackups.bat
Backups in the relational data store:
Backup_Name Status Backup_Time Mode
db_6tzxk-20190606165334426 BackupComplete 2019-06-06 19:53 scheduled
ds2 BackupRunning 2019-09-22 14:44 manual
ds2-bkp BackupRunning 2019-09-22 14:48 manual
db_6tzxk-20190925065300660 BackupRunning 2019-09-25 09:53 manual
db_6tzxk-20190925091315917 BackupRunning 2019-09-25 12:13 manual

Backups located at: 'C:\arcgisdatastore\backup\relational'.

Backups in the tile cache data store:
Backup_Name Status Backup_Time Mode
tcs_oco7oq1r-20190925065024362 BackupComplete 2019-09-25 09:50 manual

Backups located at: 'C:\arcgisdatastore\backup\tilecache'.

When I try to delete the jobs as follows, it doesn't get deleted!

PS C:\Program Files\ArcGIS\DataStore\tools> .\deletebackup.bat db_6tzxk-20190925065300660
You are attempting to delete backup 'db_6tzxk-20190925065300660'. This operation is irreversible.

Do you wish to continue (Yes or No)?Yes

Error encountered: Attempt to delete backup 'db_6tzxk-20190925065300660' is not allowed. You can only delete a manual backup that is not required for future restore.

Any support will be much appreciated..


0 Kudos
3 Replies
New Contributor

Adding to the above issue:-

I am trying to add new backup location pointing to network share. It also fails with a message 'There is a database backup process running'. So, it wouldn't allow adding new location without killing the jobs which are struck. I ran these backup jobs few days or weeks before and it had given the error message immediately saying export file can not be created. ???

0 Kudos
Occasional Contributor

Did you find a resolution to this problem? I have something similar where my backup drive filled up, because it appears that the automatic backup system is not removing the backups after the setting for "Days backup retained" has expired.I get a similar error when I try to delete one of these scheduled backups saying it can't delete because it is not a manual backup, so I'm hoping if you found a work around to using the tool, that might work for me as well.

0 Kudos
New Contributor II

Same issue here, 3 years later, on 10.9.1......starting randomly keeping backup files after the date of expiration and will not allow me to delete.