Data Store in Server manager

2192
2
06-26-2017 08:23 AM
Chiek_JiuPoh
New Contributor

Hi All,

I got some problem, After i validate, the status become like attached screen.

Appreciate if anyone could help... thank you 

After validate the status show like attached screen, how to fix this?

here are the details in log file : 

SEVERE26 Jun 2017 23:12:05The connection property set was missing a required property or the property value was unrecognized. Instance not available on serverDataValidator.GPServer
SEVERE26 Jun 2017 23:11:58Unable to process request. Service System/PublishingToolsEx/GPServer not foundRest
SEVERE26 Jun 2017 23:11:58Error getting service.Rest
2 Replies
Alexwang
Occasional Contributor II

go to gisdatastore\logs and check the log file,  or similarly you can run the describedatastore.bat under Program Files\ArcGIS\DataStore\tools to see what errors you got. for my case, port 9876 isn't listening. restarting datastore windows service solved the issue. 

0 Kudos
WinstonMcKenna
New Contributor III

I am having a similar issue with my Data Store validating within AGS and Portal. We are running Enterprise 10.7.1 in a four server federated environment.

The first error below has an error message that reads in part: "Error: failed to validate the server managed database '/enterpriseDatabases/AGSDataStore_ds_xxxxx". The server admin server is accessible and functioning as intended.  

What I have tried thus far to get things working (without success):
1. Restart the AGS Data Store on its server (test validation)
2. Within AGS admin changed the Data Store machine format from HTML to JSON (tested for validation)
3. Changed the format from JSON to HTML (tested for validation)
4. Ran the ‘update license’ tool on the DS machine (tested for validation)
5. Restarted the whole Data Store server (tested for validation)

Also, I can remote into all of my servers and they are working as intended.

So I would appreciate hearing ideas on how to resolve this Data Store issue.

Portal_invalid_datastore

ArcGIS-Server_invalid_datastore

0 Kudos