ArcGIS Portal/Server Exception setting 'ownership' role.

11653
7
06-07-2016 09:31 AM
SageWall1
New Contributor III


I've recently installed arcgis server/portal 10.4.1.  Everything appears to be working but when checking the arcgis server logs I see a lot of entries that look like:

Exception in setting 'ownership' role Failed to return the service configuration 'Hosted/DamageAssessment.FeatureServer'. Server machine 'https://AWDAGIS01.ADMIN.CO.JEFFCO.US:7443/arcgis/sharing/rest/community/self' returned an error. 'Not logged in.'

Any feedback on the cause and resolution of this exception would be greatly appreciated.

Thanks,

Sage

Tags (1)
7 Replies
JohanLundgren
Occasional Contributor

I'm also running Portal 10.4.1 and have similar messages in the log:

LogMessages.jpg

danweiss
New Contributor II

Same here...I did notice that this error only appears for Feature services - not Map services.  It's as if the Server Framework is honoring the Share settings for the service, but still throwing an error.  Like it's "failing" to reassign ownership to each user who calls the service...but not really(??)    My server is federated to the portal, for what it's worth. 

I have a ticket in with ESRI support and will post our findings when / if we get this (bogus??) error resolved.

danweiss
New Contributor II

Update:   Still working with ESRI - they are trying to replicate my environment, which is as follows;

Single virtual server (Win 2012 R2) hosting 10.4 versions of ArcGIS Server, Portal and the Data Store

Security setup is using the Enterprise Logins via SAML to talk to our ADFS server (v3.0)

I can create the referenced log entries with ArcGIS server Federated or not Federated - doesn't seem to matter; the services secured or not secured...but as you all have noticed, everything seems to work.

Collector app consuming these seemingly running fine feature services, however, seems to cause the services to eventually crash...they restart, though.  Not sure if related...

I'm going to see if I can recreate this issue in a 10.3.1 environment...

Jay_Gregory
Regular Contributor

Also have this issue (seeing same error in the logs) with a federated 10.4 portal /server environment (separate machines).  Seems to mostly affect FeatureServices, like you said, which for us is just hosted feature services as a result of analysis operations in Portal.  They often can't be added to the map, or only can be sporadically.  Would love to hear if you find any resolution to this...

0 Kudos
FabioPires
New Contributor II

I had the same problem. The difference is that my service was not in Hosted directory. However the error was the same "Exception setting 'ownership' role." in the ArcGISServer's log.
I managed to clear this error as follows:
- at ArcGIS GeoEvent Manager
- tab Site / GeoEvent / Data Stores / Registered ArcGIS Server
- edit your connection with ArcGIS Server (not Portal)
- enable Use Web Tier Authentication
- fill in the field Web Tier Username with federated user Portal for ArcGIS (not ArcGIS Server user)
- fill in the field Web Tier Password with the password Portal for ArcGIS
- click Register
Make sure the status continues with the symbol green check
Well, for me, it worked that way.

Fabio Pires

0 Kudos
danweiss
New Contributor II

Well, after working with ESRI  - both Level 1 and Level 2 support - it was concluded that the error is a non-issue.  Apparently with the release of 10.4, the devs got a little aggressive in their logging.  This is seemingly an over-response to the negative feedback they received regarding a lack of logging in versions prior...

For what it's worth, here is the scenario/path I took ESRI Level 2 support down:

  • Fresh install of 10.4 server, web adaptor and Portal on a single server.
  • Left all authentication within GIS (No identity providers, etc.)  Created 2 users: one admin- the other not.
  • Federated the server
  • Published (Shared) a single map service from ArcMap 10.4 to GIS Server; the layer appeared in the Portal as expected.
  • Ensured the owner of the layer was the portal admin account I created , shared it with a Group the non-admin account was a member of.
  • Successfully consumed the service as the non admin account.


Sure enough, the error "A request was made for service 'xxxxxxxxx.MapServer' but it did not have adequate credentials" appeared.

As this was a pretty stripped-down configuration, the error is not SEVERE (mine is a WARNING), and the layer is indeed available to permissioned users,  I am inclined to agree with Tech Support.

On to 10.4.1 !

Regards,

Dan

Jack_Zhang
Occasional Contributor

hi Dan, we are on 10.5 and have same issue when using the printing function. have you ever sorted out the problem?

0 Kudos