Address locator service adding extra 0's

101
0
02-13-2020 11:27 AM
RachelCohen2
New Contributor II

I have a composite address locator published as a service to ArcGIS portal.  This composite locator is made of several locators with suggestions enabled.  Recently, the address locator began adding 0 or 0,0 at the end of suggestions, like so:

When I run this through the rest endpoint, Find Address Candidates doesn't produce this result, it produces the correct address without the 0's.  However when I run Suggest, it does give the result with the 0's, so the 0's are a product of the suggest functionality, not the actual locator.  The locator also doesn't do this when I use it in ArcMap.  The two problem locators within the composite appear to be those associated with our streets and parcels layers.  Those locators will add the 0's in any composite locator they're put in.  I built new locators that were identical to the originals in every way, put them in an identical composite locator, and that one gives the proper results without the 0's.  The only thing that I could think might be causing this is that the original locators were recently rebuilt.  However that should not have changed any of the properties, and I can't find a property that would explain the 0's.  It appears to be looking for additional fields, probably city and zip.  

Does anyone know what might be causing this and how to fix it?  I was able to just recreate the whole thing and that worked but we want to rebuild these locators on a regular basis and don't want to have to recreate everything every time.  Thanks so much.

0 Kudos
0 Replies