Adding non-https services to Portal

1229
7
10-13-2016 09:25 AM
HaniDraidi
Occasional Contributor II

I've installed Portal for ArcGIS Server 10.4.1 and added a CA certificate to it, the portal is working very well and can consume https services from ArcGIS Server. However, when I try to add non-https services, it fails to load them and the unsafe content icon appears, so I need to click it in order to proceed.

Is there a way to enable mixed-services mode (http & https)?

Notes:

  • "Allow Access to the Portal through https only" is UNCHECCKED
  • "Allow anonymus access to your portal" is UNCHECKED

The Unsafe Content icon after adding http layer:

Any help is highly appreciated

Thank you in advance

Hani

0 Kudos
7 Replies
JakeSkinner
Esri Esteemed Contributor

Hi Hani,

Are you using Integrated Windows Authentication with your Portal?

0 Kudos
HaniDraidi
Occasional Contributor II

Hi Jake,

I am not using Integrated Windows Authentication

Thanks,

0 Kudos
DennisGeasan
Occasional Contributor II

No immediate answers but a couple things to consider.

If you are not requiring HTTPS on the Portal, take the HTTPS aspect out of the URL calling the web map.  That should eliminate the mixed content issue.

If you are required to use HTTPS due to a company IT policy, then maybe think twice about including non-HTTPS sites.  The whole point of the policy I would guess is that all communication be encrypted.  Perhaps the approach for an application requiring external non-HTTPS content is that all material be approved by management as being OK to use in non-encrypted applications.  Basic CYA.

Have you tried to access your non-Https sites with the https prefix?  If that kind of works but still throws a certificate warning, look at the certificate.  Maybe you have to change the domain part of the URL to include a fully qualified name.  The resource part of the URL has to match the certificate.

Not sure on this but try sharing the web map to 'Everyone'.  Presumably no authentication occurs for that?

0 Kudos
JonathanQuinn
Esri Frequent Contributor

Mixed mode problems aren't necessarily a Portal issue, but a browser issue.  Browsers are designed to warn users of mixed mode content.  I'd suggest avoiding that problem altogether by being consistent with the protocol you use.  If you have secure services that require logging in, just be sure you create and access the webmaps over https.  If they're not secure, you can create and access them through either protocol.

0 Kudos
HaniDraidi
Occasional Contributor II

Thanks all for the helpful input,

Seems that the issue is to use http only, since most of the services should come from other servers and these servers are non-https. My issue now changes to run my portal using http, and so my browser would not show any alerts. Is there a way to run the portal using http protocol?

0 Kudos
JonathanQuinn
Esri Frequent Contributor

Portal by default can be reached through http or https.  Login pages are always https, but My Content, the map viewer, groups, etc all can be reached through http, (as long as the option to only use SSL is not checked).

0 Kudos
DennisGeasan
Occasional Contributor II
0 Kudos