Add arcgis online vector basemap to portal?

2224
4
08-14-2016 11:20 PM
by Anonymous User
Not applicable

Has anybody done this just as an item?

0 Kudos
4 Replies
MatejVrtich
Esri Contributor

Hi,

I used the following workflow (assuming you have your own portal as well as AGOL org account):

1. save esri vector basemaps as webmap items to your own AGOL org account. Here is a list of all esri vector basemaps: http://www.arcgis.com/home/search.html?q=owner%3A%20esri_vector&t=content&focus=maps

2. use https://ago-assistant.esri.com/ to copy saved webmaps from your AGOL org account to your portal

3. share these webmaps as basemaps in your portal

Matej

RomanChueh
New Contributor III

Hi Matej,

I followed the steps you have provided and successfully added the basemaps to my portal.  But, how do I upload thumbnail images to my portal and link with the basemaps?

Thanks,

Roma

0 Kudos
MatejVrtich
Esri Contributor

Hi Roman,

this is almost a 3 years old post and the Portal technology has evolved since that time.

Don't remember the exact version of Portal, but in 10.7, you can add Esri vector basemaps to your portal just by Settings (see the attachment).

However, if you wish to replace a thumbnail of your portal item according the AGOL item, you can do it manually. From the item page, e.g. https://www.arcgis.com/home/item.html?id=358ec1e175ea41c3bf5c68f0da11ae2b, just save a thumbnail image to you local machine and upload that image to the item in your portal. I'm pretty sure you can automate this workflow using ArcGIS API for Python, but it depends on quantity of items, etc.

Regards,

Matej

0 Kudos
RomanChueh
New Contributor III

Hi Matej,

Thank you for taking time answering my questions.  I was able to upload the thumbnail images from the item page in the portal as you have mentioned, and have the thumbnail images are showing in the My Map page (shown below).   

My problem was the the thumbnail images are not accessible from the Esri Javascript 4.x web application with Basemap gallery widget (see below).

However, I was able to resolve the problem by sharing these webmaps as basemaps to Everyone instead of just to the Custom Basemaps group where these basemaps are stored.

NOTE: I am using ArcGIS Portal 10.5.1.  And with this version, there is an issue with the integration of Portal and the JavaScript API, which was reported as [BUG-000118361: BasemapGallery widget asks for login credential of portal even though group, basemaps, and layers are public.] This issue has been resolved at version 10.6.1 of Portal for ArcGIS.  (Link:  https://community.esri.com/thread/224995-basemap-gallery-requiring-login-on-public-web-map).  I believe this is related to why I was not able access thumbnails unless the basemaps are shared to public.

Thanks,

Roman

0 Kudos