Failing to login to ArcGIS Server when it is federated with Portal on Azure

07-20-2017 10:03 AM
Occasional Contributor III


the machine in question has winserver 2016 and IIS 10.

ArcGIS Enterprise pre-installed and not configured ("esri" image in the MS Azure market).

Now I'm in the process of installing and configuring the WebAdaptor.

In previous installations I checked that the URL I was using to access the webadaptor was the external DNS so that I could access arcgis server and portal from outside through port 80.

Inthis installation, I have problems in doing so for Portal in the sense that when I click on "Cofigure" in "https://<my_external_DNS>/arcgis/webadaptor/portal", it says that configuration succeeded, but the link provided does not work (a blank page shows up).

I typed in as the portal URL "https://<my_external_DNS>:7443" for portal.

For ArcGIS Server it does not even configure. I receive an error saying "Additional non-parsable characters are at the end of the string".

Strangely, unregistering WebAdaptor from Portaladmin, I can access the portal with https://<my_external_DNS>:7443, but it automatically redirects to https://<my_internal_DNS>:7443/arcgis/home/.

To be precise: redirects to . I think this is the problem and this is how the installation provided with the image was dsigned.

If I use the internal_DNS I can succesfully configure the WebAdaptor, but I had other problems, like not being able to login to arcgis/rest/services (after pressing login I was receiving a Timeout Exceed error).

The only source I could find to be of help was this other thread, specifically one comment saying "I had a similar problem on my Windows network system.  Seems it was because I had initially setup things using our internal network names (before installing our SSL certs).  I needed to unregistered portal from the Web Adapter and then go through the setup using the public domain name the cert was applied to.".

I need this to work as it should have been easier than installing everything from scratch, but it is getting even way harder...

Aprreciate any help.

0 Kudos
5 Replies
Occasional Contributor III

Still struggling to get it working. I uninstalled the webadaptor to hopefully connect from ArcMap at least, but when I do it I receive an error saying "Error: Unable to acquire authentication token."

Also, i noticed that when I try to access the URL "" from outside, ArcGIS Server REST opens up, but when I try to login, it keeps redirecting me to the internal

which is never resolved obviously, because it's only seen from within the same virtual and nowhere else.

0 Kudos
Occasional Contributor III

I just changed the title because it seems the real problem comes when federating the ArcGIS Server with Portal.

WebAdaptor is now working just fine. I can connect to my ArcGIS Server machine from within ArcMap using the external URL and credentials with no problem.

As long as I federate the server with the Portal, I cannot connect anymore. Morevore, if I try to login to ArcGIS Server (e.g.) REST, I am redirected when doing it from the visrtual machine, and I receive a Timeout Exceed error from another machine, with the URL being very strange (something like "https://servername/arcgis/login?ReturnUrl=https://servername/arcgis/rest/services). I also tried the solutions provided in this thread, but noe of them solved the problem.

I am using a Self signed certification, could this be the real problem?


0 Kudos
New Contributor II

Hello, did you find a solution? We are having the same issue with 10.6.1 too

0 Kudos
Esri Contributor


Did you find a solution to this? I am experience similar issue but with 10.7.1. Before federation, access to GIS Server via ArcMap or web browser was perfect. After Federation, i receive a timeout errror in ArcMap when trying to connect ( Add a GIS Server in Catalog) and also "timeout exceeded" error in web browser when trying to access Manager. All from within the one virtual machine


0 Kudos
by Anonymous User
Not applicable

Did anyone find a solution? After restarting both ArcGIS Server and Portal for ArcGIS, the redirect issue is occurring where it wasn't before. 

0 Kudos