Portal url parameter is not honored

644
2
Jump to solution
04-21-2017 01:50 AM
JacobNicolajsen
New Contributor II

Hi,

I'm trying to make a default config.xml for my organisation, to be used with silent installation. The installation works fine, but my portal url parameter is not honored. I only get arcgis.com

Here is what I've a added to the config.xml used in the installation:

<portals>   
   <portal url="https://geov.dk/portal" />
   <portal url="https://www.arcgis.com" /> 
</portals>


Is this a bug or am I doing something wrong?
Other parameters like units and banner text are working as expected.

0 Kudos
1 Solution

Accepted Solutions
XuewenZhang
Esri Contributor

Hi Jacob,

I just tested your portal in ArcGIS Earth V1.4 and it worked will on my side.

I think there are two reasons for your case:

  1. If you can see your portal with an admin icon in the portal manager, then it might be the portal in user config.xml is still https://www.arcgis.com. The user config.xml is for logging the user settings and you can find it in C:\Users\...\AppData\Roaming\ESRI\ArcGISEarth.
    • You can clear the user folder if you don't want to keep the old config and then try to launch ArcGIS Earth.
  2. If you can't see your portal in the portal manager, then it might be the format of your config.xml is not V1.4 when installing. 

Best,

Xuewen

View solution in original post

2 Replies
XuewenZhang
Esri Contributor

Hi Jacob,

I just tested your portal in ArcGIS Earth V1.4 and it worked will on my side.

I think there are two reasons for your case:

  1. If you can see your portal with an admin icon in the portal manager, then it might be the portal in user config.xml is still https://www.arcgis.com. The user config.xml is for logging the user settings and you can find it in C:\Users\...\AppData\Roaming\ESRI\ArcGISEarth.
    • You can clear the user folder if you don't want to keep the old config and then try to launch ArcGIS Earth.
  2. If you can't see your portal in the portal manager, then it might be the format of your config.xml is not V1.4 when installing. 

Best,

Xuewen

View solution in original post

JacobNicolajsen
New Contributor II

Thank you very much. 

Clearing the user folder did the trick.

Best,

Jacob