Update10.0 to 10.4 problem

654
3
09-20-2016 02:46 AM
AnthonyGreenish
New Contributor

I am trying to update from 10.0 to 10.4 but I keep getting the message that there are 10.0 components. I have run the uninstall utility and get the message there are no 10.0 components left but when I try to install 10.4 it keeps finding 10.0 components. what can I do?

0 Kudos
3 Replies
RebeccaStrauch__GISP
MVP Esteemed Contributor

Which software are you trying to install?  Desktop or ArcGIS Server.  You currently have this in the ArcGIS Online space.  You may want to try Moving your Content‌ to the https://community.esri.com/groups/arcgis-for-desktop-installation-support?sr=search&searchId=652bbbd...‌ or https://community.esri.com/community/gis/enterprise-gis/arcgis-for-server?sr=search&searchId=351a5a0...‌ for example, which ever is more appropriate.

JayantaPoddar
MVP Esteemed Contributor

For ArcGIS Desktop,

Two options that I can suggest:

1. Download the PatchFinder.exe and run to see if any component is left.

2. Else remove the dirty files/folders/RegistryKeys manually

Rename or delete following folders:

C:\Program Files (x86)\ArcGIS

 C:\Program Files (x86)\Esri

 C:\Program Files (x86)\Common Files\ArcGIS

 C:\Program Files (x86)\Common Files\Esri

 C:\Program Files\ArcGIS

 C:\Program Files\Esri

 C:\Program Files\Common Files\ArcGIS

 C:\Program Files\Common Files\Esri

 C:\Program Data\Esri

 C:\Program Data\ArcGIS

 C:\Program Data\FLEXnet

 C:\Users\<USERNAME>\AppData\Local\ESRI

 C:\Users\<USERNAME>\AppData\Local\ArcGIS

 C:\Users\<USERNAME>\AppData\Roaming\ESRI

 C:\Users\<USERNAME>\AppData\Roaming\ArcGIS

 C:\ProgramData\Microsoft\Windows\Start Menu\Programs\ArcGIS

 C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Esri

 

Go to regedit (RUN > REGEDIT) and rename/delete the following (if they exist):

 

 HKEY_LOCAL_MACHINE\SOFTWARE\ESRI

 HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\ESRI

 HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Flex LM License Manager

 HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\<Delete Any Folder that contains ArcGIS or Esri>

 HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\ArcGIS Server

 HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\<Delete Any Folder that contains ArcGIS or Esri within>

 HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\FLEXnet Licensing Service

 HKEY_CLASSES_ROOT\Installer\Products\<Delete Any Folder that contains ArcGIS or Esri within>

 HKEY_CLASSES_ROOT\Installer\Assemblies\<Delete Any Folder that contains ArcGIS or Esri within>

 HKEY_CLASSES_ROOT\<Delete and Folder that contains ArcGIS or Esri within>

 HKEY_CLASSES_ROOT\Installer\Assemblies\Global\<Delete all Keys beginning with ESRI or ArcGIS>

Then REBOOT.

AvinashPatel1
Occasional Contributor III

First, you need to uninstall all old component that’s related to 10.0 specially external software’s if any.

After the uninstall activity reboot system and start the installation process for fresh copies of the applications (Server, desktop or others)