Upgrade from Desktop 10.3.1 to 10.6.1, system requirements erroneously reports Visual C++ package missing?

1454
6
04-29-2019 09:55 AM
NathanTaylor3
New Contributor II

Trying to upgrade from 10.3.1 to ArcGIS Desktop 10.6.1, setup.exe won't run. When I try to run setup.msi (UI and silently), I get an error "Desktop 10.6.1 requires Microsoft Visual C++ 2017 Redistributable (x86) 14.12.25810 or greater to proceed". I do indeed have this package installed (tried with actual 14.12.25810 package and also newer version). Have tried uninstalling/reinstalling with new C++ download from Microsoft. Nothing working. Any ideas?

0 Kudos
6 Replies
MichaelVolz
Esteemed Contributor

You are trying to install ArcGIS 10.6.1 on the same computer that had ArcMap 10.3.1?  If so, maybe this is an erroneous misleading warning and you still have custom or 3rd party software installed on the machine that is connected to ArcMap 10.3.1.

Have you tried the same install on another computer with the same Microsoft Visual C++ 2017 Redistributable (x86), but ArcMap 10.3.1 has never been installed on the computer?  I'm just thinking this might indicate that the other computer still has ArcMap 10.3.1 remnants.

0 Kudos
NathanTaylor3
New Contributor II

Thanks Michael. I tested 10.6.1 setup on another machine with no ArcGIS software or history of install, an older C++ package, and setup ran successfully. Following your logic about "remnant" 10.3.1 files being the culprit, I uninstalled 10.3.1 via Control Panel-->Programs (though I question how thorough a Windows uninstall really is), manually deleted Windows ArcGIS 10.3 Program (x86 and App Data) folders, and even removed Esri software entries from the registry. Then I uninstalled C++ packages entirely. Setup exe still wouldn't run (If incorrect C++ version, setup should auto-install the correct C++, this .exe file exists in the setup package). I've endured this  "purging" process twice now, on my own time and on the phone with Esri support. Still nothing.

0 Kudos
LaureneKoman
Occasional Contributor III

We couldn't repro this at Esri. We installed the same redist you had installed and we could successfully install ArcGIS Desktop 10.6.1 after.  Try installing the redist that's available in the setup files (in the \setupFiles\support folder) before you try to install ArcGIS Desktop (setup.exe or setup.msi) and see if the redist will successfully install outside of our process. 

Thanks

Laurene Koman

ArcGIS Installation Team 

NathanTaylor3
New Contributor II

Thanks Laurene. I ran the vc_redist.x86 in this location \SetupFiles\Support\VCREDIST after uninstalling all C++ redists. It effectively installed 12 C++ redists from 2005-2017, both x86 and x64 versions (see pic below). After this, setup.exe still wouldn't run. Actually, this time setup.exe didn't throw the error in the screenshot above (it was throwing error earlier) but it did nothing at all. Totally unresponsive. When I ran setup.msi, thats when the error message displayed.

Note that the 14.12.25810 redist in the error wasn't installed in the ArcGIS 10.6.1 support files redist. A more recent version installed instead (14.15.26706). Now I'm going back to Microsoft downloads and manually installing all these above versions.

0 Kudos
curtvprice
MVP Esteemed Contributor

The install download package includes the needed Visual C++ stuff (Desktop\SetupFiles\Support\VCREDIST), and setup.exe is wired to look for it and install it for you. So my recommendation is uninstall your C++ packages, and then running setup.exe instead of setup.msi. (Setup.exe by the way takes all the msiexec arguments the msi does if you need to do your install silently.)

0 Kudos
JohnRyan
Esri Contributor

If you still cannot get the C++ redistributable to work, some solutions posted for issues with redistributables on other applications may assist here. Such as the following described on 

https://answers.microsoft.com/en-us/windows/forum/windows_7-windows_install/microsoft-c-redistributa...

Sometimes you might need to uninstall an existing version of the Visual C++ Redistributable in order to resolve problems affecting it. If installing the correct Visual C++ Redistributable does not resolve problems installing or repairing a program, it likely means that one of the DLL files might be corrupt. Re-registering the DLL files might be able to resolve the problem.

Press Windows key + X then click Command Prompt (Admin) or Windows PowerShell (Admin). At the command prompt or PowerShell window, type the commands below then hit enter after each. Exit the command prompt then restart your computer to see if the problem is resolved.

regsvr32 ntdll.dll /s

regsvr32 msdxm.ocx /s

regsvr32 dxmasf.dll /s

regsvr32 wmp.dll /s

regsvr32 wmpdxm.dll /s

Encountering problems with the Visual C++ Redistributable is a rare occurrence, but it’s also a sign of the legacy issues still attached to Windows. The Universal App model minimizes the need for such components because of the new packaged based deployment used. For big apps like AutoCAD, QuickBooks, Adobe Creative Suite and iTunes, this component will always be a part of your apps’ fundamental architecture. Hopefully, this article will help you overcome any obstacles if you do encounter them.

(Explanation from https://www.groovypost.com/howto/fix-visual-c-plus-plus-redistributable-windows-10/)

0 Kudos