Survey123 embedded in Ops dashboard does not allow me to "use my location"

279
3
04-09-2020 08:01 AM
StefanieWenker
Occasional Contributor

I have created a survey in the Survey123 web designer and I want to embed this survey in Operations Dashboard. I am anticipating that my end users will want to use it on mobile and so I was trying to use my embedded survey on my android phone and on my Ipad. 

I think it is not working correctly on both. On my phone the geolocate question does not ask me if I want to use my devices location after I click on the map, which means I have to use search or zoom in a whole lot. On my Ipad when I have the option to "use device location" turned on, the map doesn't work at all. When I click on it, it doesn't do anything. When I opened the survey in its own browser on my Ipad I did get the pop-up asking if I wanted to use my location and the map worked.

I did try turning off the "use device location" option in the web designer and the map does work for both devices in this case. However if one person was doing a number of surveys (which is what I am intending) the zooming would get pretty old.

Sidenote: I tried using the embedded survey in Chrome instead of Safari on my Ipad and it allowed me to expand the survey to the full screen. The "use my location" function still didn't work in there.

0 Kudos
3 Replies
DerekLaw
Community Moderator

Hi Stefanie,

> Survey123 embedded in Ops dashboard does not allow me to "use my location"

I just did a quick test of the following:

- Created a new survey in Web Designer with a map question, deployed as a web form;

- Embedded the web form in a dashboard

- Opened the dashboard on my iPhone 7 in Safari

- And when I click the "locate" button, it prompts me to use my device location - so I am unable to reproduce your issue.

FYI: The Map question can only get your location from the device if you allow users of the web browser to get that location. This is a security setting of the device, typically in the OS.

For your iPad, please try Settings > Privacy > Location Services > then I select Safari Websites > (Allow Location Services) While using the App

Not sure about your Android device.

Hope this helps,

0 Kudos
StefanieWenker
Occasional Contributor

Hi Derek, 

Thank you for looking into it. I have found the issue:

My operations dashboard was defaulting to http:// instead of https:// when I add the s to my link it works (at least in Edge) still having some trouble with Chrome, but it is due to my privacy settings.

We will have to get a move on to move all of our services to https

0 Kudos
DerekLaw
Community Moderator

Hi Stefanie,

Glad to hear your issue is resolved.

Stay safe!

0 Kudos