Serial Charts no longer able to filter map content

1832
9
Jump to solution
04-15-2021 07:53 AM
OlyPowers
New Contributor III

In October I created a series of dashboards using Dashboards Beta for one of our departments. The feature they loved the most was being able to click on the columns in the serial charts, and have only those features show up on the map. The filter action between the serial chart and the map worked in October. Here I am in April now, trying to create another of these dashboards for another department. I have set up everything the same as I did the previous ones. However when I go to add the filter action for the serial chart, the map layer is not showing up as a target  at all. I have quadruple checked that the serial chart is using the correct data source. It is. I have recreated the serial chart several times. Finally I went back to dashboard that I know was working to find out that the filtering from the serial chart to the map is no longer working. When I go to the action panel in the chart, "The target element has a configuration issue" is showing up underneath the map layer target. Something has happened recently that's not allowing the map layers to be used as filter targets anymore. This is a great feature that a lot of people use to explore the data, why is it no longer working?

0 Kudos
1 Solution

Accepted Solutions
JohnSolly4
Esri Contributor

Hello,

We have a known limitation where map services cannot be used to perform filter actions in grouped value charts. We are working on a fix, but it didn't make it into the latest release.

 

As the other user mentioned, we just came out of beta, so accessing Dashboards from your content page now point to the new dashboards. 


Can you let me know if there is a difference between opening the dashboard from the following two locations?

https://www.arcgis.com/apps/opsdashboard/index.html#/home

vs

https://www.arcgis.com/apps/dashboards

 

I am suspecting you are using a map service for your chart. We have known limitations with map services taking part in filtering other elements (like the map).

 

View solution in original post

9 Replies
GeorgiaCummins
New Contributor III

ArcGIS Dashboards is out of Beta now (https://community.esri.com/t5/arcgis-dashboards-blog/new-arcgis-dashboards-is-out-of-beta/ba-p/10471...
I have a dashboard that is no longer working too. I think this might be the reason. 

0 Kudos
JohnSolly4
Esri Contributor

Hello,

We have a known limitation where map services cannot be used to perform filter actions in grouped value charts. We are working on a fix, but it didn't make it into the latest release.

 

As the other user mentioned, we just came out of beta, so accessing Dashboards from your content page now point to the new dashboards. 


Can you let me know if there is a difference between opening the dashboard from the following two locations?

https://www.arcgis.com/apps/opsdashboard/index.html#/home

vs

https://www.arcgis.com/apps/dashboards

 

I am suspecting you are using a map service for your chart. We have known limitations with map services taking part in filtering other elements (like the map).

 

OlyPowers
New Contributor III

It only opens in the second link. The dashboards were created in beta and do not exist in classic.

That's interesting that there are known limitations for filtering from feature services when that was definitely working before.

After a lot of testing today I was able to get the filtering working by converting our map service to a feature service, and re-adding the layers to the maps one at a time. This is still going to be a lot of working to re-point and re symbolize everything, but it'll get the dashboard working the way we need it to.

JohnSolly4
Esri Contributor

I suggest reaching out to support about any Dashboards that are not opening.

0 Kudos
OlyPowers
New Contributor III

I mean that's not really the problem. A dashboard that was created in Beta simply doesn't exist in Classic. That was never the issue.

0 Kudos
JohnSolly4
Esri Contributor

I think I see what you are saying @OlyPowers 

 

When you create or save a dashboard using the latest Dashboard, https://www.arcgis.com/apps/dashboards you will no longer be able to open that dashboard using the Classic application, https://www.arcgis.com/apps/opsdashboard

 

These are two separate applications. The latest Dashboards will be able to open and edit older dashboards, but you won't be able to use the older application to open newer dashboards.

 

I hope that clarified things? I am doing my best to understand the problem you are raising!

0 Kudos
BrittanyBurson
Occasional Contributor III

Hi @JohnSolly4 - Enterprise 10.8.1 here.

Is one of the known limitations with "grouped" rest service endpoints? I can't seem to get the Filter Map option for the map when using the service URL of 

https://maps.example.gov/arcgis/rest/services/Example/Utilities_Example/MapServer

BrittanyBurson_2-1636577656713.png

 

 

but I can if I use the single endpoint URL in the map..

https://maps.example.gov/arcgis/rest/services/Example/Utilities_Example/MapServer/4

BrittanyBurson_1-1636577620428.png

If it is not the group, is there something else causing it?

Thank you

0 Kudos
MoyaCalvert_01
New Contributor

@JohnSolly4 is there an update on this issue - reading this - you say "map services cannot be used to perform filter actions in grouped value charts. We are working on a fix, but it didn't make it into the latest release", written nearly 10 months ago.

I am using a hosted service on ArcGIS Online, one of the best features was that you could click on a bar in the serial chart and the map would filter to display the data from that bar.  but this feature has disappeared (!)  My chart is set up for Grouped values, so I am figuring this is the problem.  but there doesn't seem to be a solution???  

0 Kudos
ShaneBradt
New Contributor III

Hi @JohnSolly4! I agree with @MoyaCalvert_01 - I love using a bar graph to let users filter other content. The only way I can create the graph I need is by using grouped values. Can you provide any update on the fix to this issue? Thanks!

0 Kudos