Select to view content in your preferred language

Pop-ups not working in dashboard

2824
11
Jump to solution
03-24-2022 03:47 AM
DarraghOSullivan
Occasional Contributor

Hi all,

Pop-ups in our dashboards are no longer working - no error message or anything, nothing happens when clicking the feaure. The underlying Web Mapa are working fine, with pop-ups showing in the Map Viewer.

I've tried in Chrome and Edge but similar results. 

Any ideas, thank you?

1 Solution

Accepted Solutions
DarraghOSullivan
Occasional Contributor

Ours seem to be back working again today. Maybe a bug was fixed or something?

View solution in original post

0 Kudos
11 Replies
JayantaPoddar
MVP Esteemed Contributor

Are you using a Map Service for the layer for pop-up?

Try using a Feature Service or a Hosted Feature Layer instead, and let us know if it works.



Think Location
0 Kudos
DarraghOSullivan
Occasional Contributor

Thank you @JayantaPoddar . Yes the dashboard uses a Hosted Feature Layer already. Should have said it's all in AGOL.

0 Kudos
jcarlson
MVP Esteemed Contributor

Your dashboard's map widget can have a setting to suppress popups. Can you confirm that popups are enabled on the widget?

- Josh Carlson
Kendall County GIS
0 Kudos
DarraghOSullivan
Occasional Contributor

Thank you @jcarlson . Yes I can confirm that the popups are enabled in all widgets.

0 Kudos
AlessioDiLorenzo
New Contributor III

Same issue for us.

Nothing changes if the layer comes from arcgis server mapservice, arcgis server feature service or agol hosted feature service. We tried all of these

0 Kudos
DarraghOSullivan
Occasional Contributor

Ours seem to be back working again today. Maybe a bug was fixed or something?

0 Kudos
AlessioDiLorenzo
New Contributor III

Ours continue not working for now

0 Kudos
SandraLuken1
Esri Contributor

Hi Yes, this should be resolved now. Can you confirm that the pop-up is also not showing in the map viewer as well as dashboards?  Is there is an example that can be provided, or can work with Esri technical support to reproduce the issue. 

0 Kudos
AlessioDiLorenzo
New Contributor III

Hi @SandraLuken1,

pop-ups are working now.

Thank you.

0 Kudos