Pop-Up Not Working in Map Widget

1158
5
10-08-2018 09:17 AM
MitchHolley1
MVP Regular Contributor

I have created an operations dashboard that contains a map widget.  The web map this widget is pulled from has pop-ups enabled that function properly inside the web map.  However, when the dashboard is viewed, none of the pop-ups work.  Does anyone have any ideas.

I am using a Hosted Feature Layer in the web map.

Tags (2)
0 Kudos
5 Replies
BenjaminMittler
Occasional Contributor III

In the map configuration, under general, check to see that your text color isn't set to white. 

Same thing just happened to me and this was the solution. 

MichaelVolz
Esteemed Contributor

Were you initially using all default colors when you discovered this issue or had you already modified either the text or background to be white so the text was not visible?

0 Kudos
BenjaminMittler
Occasional Contributor III

I had never touched the settings for the text color in pop-ups. 

What I did do was change the overall maps color settings. I had changed my dashboard colors to dark green and changed my text to white so that I could see the text in my header. 

For some reason changing the text to white in the dashboard properties also changed the popup setting to white text, despite the fact the the background color for the popup is white. 

0 Kudos
MichaelVolz
Esteemed Contributor

So there is no separate text color setting for text in the map and text in the pop-up?  If that is the case, that seems like something ESRI should fix so they are separate and more granular.

0 Kudos
BenjaminMittler
Occasional Contributor III

There are two separate settings. One for the text in the dashboard (header), and one for the text in the map (popup). What happened to me is that I changed my dashboard theme from dark to light, this overrode the text color settings for my map so I had to go back and change them.