Operations Dashboard with Secure Services

4743
6
09-18-2013 12:52 PM
GrantCarroll
New Contributor
Hi All

I have a web map that has been created with a secure service. I now want to use this webmap within the Emergency Operations dashboard, however I get prompted that I need a certificate and then I can't access the webmap. What is the process for generating the certificate and I assume that any machine that wants access to this map needs the certificate. It would be a lot nicer if we could just enter the username and password to access the secure service.

Please help, the service needs to be secure because it deals with building inspection information from emergency events, so it is sensitive data, and I'd rather not have it publicly available.

Thanks
0 Kudos
6 Replies
PeterTimmers
Occasional Contributor III
Are the secure services registered with ArcGIS Online?

We've got secure feature services registered with ArcGIS Online and with the login stored in ArcGIS Online and that appears to work.
0 Kudos
GrantCarroll
New Contributor
Are the secure services registered with ArcGIS Online?

We've got secure feature services registered with ArcGIS Online and with the login stored in ArcGIS Online and that appears to work.


Do you mean as a hosted service with ArcGIS Online ? I don't want or need to do this as I have information coming into the services through a custom application, also the services are linked to a wider database handling emergency management, so I need to have the services being served off my ArcGIS Server. Or maybe I have missed something ?
0 Kudos
PeterTimmers
Occasional Contributor III
No our services are hosted on a 10.1 ArcGIS Server situated in our DMZ with AGS maintained security with our data on a SQL Server inside the firewall.

If I register those services and their password with AGOL then they work.

Mind you as I said in the other thread here... it's crashing a bit.  And giving me little triangles with exclamation marks - ie. disconnection notifications I imagine.    I'm wondering whether it's our firewall now.  It's even stopping me logging back on... saying things like I'm getting the password wrong.. which I know I'm not.   All sorts of trouble and with the way it is it's not something I can give to anyone else in our dept. Yet

btw Our data is emergency management data also... emergency current incidents, aircraft and vehicle tracking.
0 Kudos
GrantCarroll
New Contributor
Ok, thanks for the info. I'll give it a crack and see what I can come up with. I'll let you know.

Cheers
0 Kudos
MichaelParma
New Contributor III
Did anyone ever find a resolution for this? I've registered a local secure map/feature services in my AGO account and stored my login credentials. I then published the feature service to a web map. In the Operations Dashboard, the web map widget works fine. However, in my summary widgets the service (report) is not recognized.

Thanks,
Mike
0 Kudos
JayChen
New Contributor III

Hi Michael,

Do you get a chance to watch the traffic using fiddler app? If not, can you give it a try and see if there any request or response that are suspicious?

Thanks,

-Jay

0 Kudos