Operations Dashboard showing wrong date for features?

4510
5
Jump to solution
08-06-2014 09:30 AM
SpencerCherry
New Contributor

I have a map running in Operations Dashboard and I just noticed that the date attributes of features are all showing the wrong date.  They all show the day before the actual date.  The dashboard is running off of a service published to our AGO organization account.  The service was published from features contained in a file geodatabase and the dates are correct in the date field in the file geodatabase.

 

Any assistance explaining what is causing this error and how to fix it would be greatly appreciated.

0 Kudos
1 Solution

Accepted Solutions
CarolGhostine
Esri Contributor

ArcGIS Online expects the data format to be in UTC,  so it was converting the dates in the file geodatabase to UTC time when it was published as a service to ArcGIS Online.,

To address this you'll need to use the date conversion tool in ArcMap before you publish your service to AGOL

  1. Go to Toolboxes
  2. System toolboxes
  3. Data Management Tools
  4. Fields
  5. Convert Time Zone

The output time should be (UTC) Coordinated Universal Time. The date format should appear correctly in the web map and ops dashboard.

-Carol

View solution in original post

5 Replies
CarolGhostine
Esri Contributor

Hi Spencer,

Are you able to share your service and op view with me?

If you add me to a group in you organization I can access the op view.

-Carol

0 Kudos
SpencerCherry
New Contributor

Hi Carol,

If you are still willing to help me look into the issue of the dates displaying wrong (one day early) in operations dashboard I can temporarily add you as a member of our organization so you can see the issue. I think that I just need an email address to send the invitation to.  Thanks.

Spencer Cherry

0 Kudos
CarolGhostine
Esri Contributor

ArcGIS Online expects the data format to be in UTC,  so it was converting the dates in the file geodatabase to UTC time when it was published as a service to ArcGIS Online.,

To address this you'll need to use the date conversion tool in ArcMap before you publish your service to AGOL

  1. Go to Toolboxes
  2. System toolboxes
  3. Data Management Tools
  4. Fields
  5. Convert Time Zone

The output time should be (UTC) Coordinated Universal Time. The date format should appear correctly in the web map and ops dashboard.

-Carol

View solution in original post

ReginaldoPaderon1
New Contributor

I have the same issue.  The Date in my database is correct but what is displayed in my Dashboard is 3 hours ahead ( I am from Middleast - Qatar ( UTC + 3 hrs ).  We are in operation and records are being added on a daily basis.  I think this solution does not apply to us.  I would like to reflect the Date field on my Dash.

 Any suggestion ?

AshleyCassol
New Contributor II

Do I have to run this tool for every table and every field that has a date in it??