Select to view content in your preferred language

Operations Dashboard not displaying all features.

10-13-2020 06:33 AM
by Anonymous User
Not applicable

I have an operations dashboard that contains a merged layer. The user selects the year and features with that year value display. 

What is happening is that the operations dashboard is acting as if there is a scale dependency or that the number of features it can return is exceeded and will not draw all features when zoomed to the full extent. Features appear as you zoom in but I want all features to appear at the full extent.

The number of features visible is NOT above the default maximum record count (2000) in many cases. Also, when I load data for one year in as a separate layer, all features draw just fine. The filter is having a weird effect. 

I used a registered map service and set the maximum record count to a number higher than the total number of records in the merged feature class - It it impossible for there to be more features displayed than the service can handle, but I still have the same effect.

Features draw as desired in the web map that feeds the dashboard. 

Any advice on this matter would be very very much appreciated. Thank you,

Randy McGregor

0 Kudos
2 Replies
New Contributor III

I've been encountering the same problem and have been looking for workarounds, or configuration settings, or even some basic documentation which states what the actual feature limit is for Operations Dashboards to not encounter this wierd filter bug.

One way would be to create a separate layer for each of the years with definition queries; since this filter seems to happen before the dashboard limit sees them, this works as long as your per year count is lower than the max, but this complicates the UI as you'll need to have some layer picker available on the dashboard and I doubt you can configure it to force the user to only select one year at a time, and multiplies the configuration work of any other widgets looking at the data.  

Edit: Also worth nothing the Map Image Layers always draw correctly, but since those layers can be filter/action targets it's not useful as a solution in this case.

I'm going to try to see how the WebAppBuilder widgets that have similar effects to the dashboard work out but I'm curious if you encountered anything else, maybe some service parameter which lets the dashboard get more features for display/filter.

0 Kudos
New Contributor

I was having the exact same problem with the year filtering and layers not showing up at certain extents. This article from ESRI eventually solved my problem. I chose to set my scale to "world" (slide it all the way to the left) which fixed it. . Hope it works for you too.

0 Kudos