Operations Dashboard BUG

2066
7
01-23-2017 01:12 PM
DaveMcMillan
New Contributor III

Operations Dashboard Question BUG:

I have a web map with two feature layers that are a "hosted view", this map is for public consumption showing construction closures (see link below to the web map)

PUBLIC MAP

http://countyofriverside.maps.arcgis.com/home/webmap/viewer.html?webmap=9f3f59e887c342d18fe3034735dc... 

I have a second web map that has the feature layers and they are editable and are used in an internal group not the general public.

Both maps have filters on the feature layers that only show roads that are closed. 

Both web maps work as expected and only roads that are closed show up.

Now I am taking the PUBLIC web map and creating a multi display operational  view  and a single display operational view to embed this into our website using operations dashboard (See link below)

Operations Dashboard 

When I view the maps opening operations dashboard both views show me only closed roads, when I share a link to the view and open the same map again in a web browser all roads show up, even though I created a filter?

I tried creating filters in operations dashboard, but was only successful getting the open roads to not show in the widgets, they still show up on the map.

Any thoughts or is this a BUG in the software.

Thanks,

Dave McMillan

0 Kudos
7 Replies
ChristopherOlsen
Regular Contributor

Hi Dave,

Yes, this is a bug in web Dashboard with filtered hosted views.  As you mentioned, this is only seen in web dashboard and works perfectly fine in the desktop dashboard and even in our new beta app

A workaround would be to add the data to the webmap via the service URL. I found that when you did that, it respected the filter.

I've added this thread into our bug information and if you have any other questions, just let me know.  


Thanks!
Chris

0 Kudos
DaveMcMillan
New Contributor III

The workaround did not seem to work

0 Kudos
ChristopherOlsen
Regular Contributor

Can you add a feature with closed=no back in? Looks like its just the one feature in the table now.

0 Kudos
DaveMcMillan
New Contributor III

Try it now I added a road with closed = no    

with the filter applied

0 Kudos
ChristopherOlsen
Regular Contributor

Here's a sample web dashboard using both showing that using the URL directly in the web map instead of the item in AGOL.  I put some summary widgets on as well to show the difference and you can toggle the items via map tools.

Operations Dashboard 

0 Kudos
DaveMcMillan
New Contributor III

Ok thanks,

I Will give it another shot it looks like you got it to work.

Also, I appreciate the quick response to my initial question.

Dave

DanMcCoy
Occasional Contributor III

Has this been fixed in the current release?  If not, what's the BUG#?

Thanks,

Dan

0 Kudos