Maps and layers not visible on Dashboards

606
8
Jump to solution
4 weeks ago
TsedevGankhuyag
New Contributor II

Hello,

I prepared Dashboards in ArcGIS Online. But when I change sharing level of layer from owner to public, it disappeared from my Dashboard(Photo attached). And then switch sharing level from public to owner, it is visible to Dashboards. I enabled anonymous view from Organization Setting. But still has problem to no showing. I would like to share my Dashboards to people that out of organization. Could you assist me?

1 Solution

Accepted Solutions
DerekLaw
Community Moderator

Hi @TsedevGankhuyag

If you're sure that you've enabled all the sharing permissions correctly on the survey and the web map, and are still getting this error, then I would suggest you contact Esri Tech Support to help you investigate further.

The error messages on the various dashboard elements indicate that the dashboard is unable to access the data layers powering them - so it is a data access/permissions issue.

View solution in original post

8 Replies
JayantaPoddar
MVP Esteemed Contributor

Keeping the Sharing level="Everyone", are the features displaying properly in the webmap (that is used in the dashboard)?

If possible, could you share the URL of the webmap and the dashboard?

0 Kudos
TsedevGankhuyag
New Contributor II

Below is Dashboards link.

https://www.arcgis.com/apps/dashboards/912027094c5948e9830072bcb1d697fc

I collected data using Survey123 and created web map using hosted feature layer. Sharing level of all layers, web map, dashboards are Public (photo attached). As you can see in Dashboard, map and layer data not visible aside from layer that uploaded from computer in Dashboards even all of it is "Public" (photo attached).. It is also not visible for me. Then all values visible for me when I change sharing level from public to owner(Photo attached). But owner setting means I am unable to share to others. 

0 Kudos
JayantaPoddar
MVP Esteemed Contributor

It is not a good practice to keep the hosted feature layer as a public data collection.

Please go to the Settings of "Bird Observation Khanbumbat" > Disable Public Data Collection. Also disable editing, if already enabled.

JayantaPoddar_0-1622520443368.png

 

JayantaPoddar_1-1622520493887.png

Save the settings. Share the layer with public. Check if the features of the layer are visible in dashboard.

Additional Info:

You may opt to create a hosted feature layer view, in case the layer is being edited on web or using a view only layer for public.

Working with Hosted Feature Layer Views and Public Data 

0 Kudos
TsedevGankhuyag
New Contributor II

I tried. But still same problem. I created new feature view layer and map. Sharing level is public. But still same problem. All layer values unable to see when change from owner to public. Anonymous setting is enabled.  :(((

0 Kudos
DerekLaw
Community Moderator

Hi @TsedevGankhuyag

Just to verify, did you ensure that you also set the sharing permissions of the survey results to "public" as well? You can check when you login to the Survey123 website > select survey > Collaborate tab > Share results.

Survey123_Permissions.png

Hope this helps,

0 Kudos
TsedevGankhuyag
New Contributor II

Hello @DerekLaw 

I set sharing permission of survey results to public. Layer and map also set for public view. But as you can see, layer values still not visible in Dashboards. It is only visible when I change layer status to owner. :((

0 Kudos
DerekLaw
Community Moderator

Hi @TsedevGankhuyag

If you're sure that you've enabled all the sharing permissions correctly on the survey and the web map, and are still getting this error, then I would suggest you contact Esri Tech Support to help you investigate further.

The error messages on the various dashboard elements indicate that the dashboard is unable to access the data layers powering them - so it is a data access/permissions issue.

View solution in original post

TsedevGankhuyag
New Contributor II

Many for assisting me. Dashboards values are visible now. I was mistaken. 

There was only "Fieldmaps layer" that was automatically created when I publish Survey form in Links tab < Survey123 Connect. Then I created map using that Fieldmaps layer not Stakeholder or General layer.  After that it is visible on Dashboards. But when I use Stakeholder or new created view layer, it is not visible again.

Thanks again all. :))

0 Kudos