Indicator and Gauge Elements Not Displaying Correct Count Values in Operations Dashboard

06-05-2018 04:16 PM
Esri Contributor

Operations Dashboard for ArcGIS

I have a polygon feature class with a related table of inspection records, and both the feature class and related table have attachments enabled on them (i.e., when collecting a new polygon feature in Collector, field crew can attach pictures to it; when inspecting an existing polygon in Collector, field crew can attach pictures to their new inspection record as well). 

In my Operations Dashboard, I have configured the following elements:

  • Details Element: Shows me the details of all 22 records in my related table of inspections
  • Gauge Element: Should show me the count (i.e., 22) of records in my related table of inspections
  • List Element: Shows me a list of inspection records that found damages (currently, only one inspection found damages)
  • Indicator Element: Should show me the count (i.e., 1) of inspection records that found damages

In my Gauge and Indicator Elements, they do not show the correct count values of 22 or 1, but rather they show incorrect count values of 1 and 0, respectively. However, when I say "Show data table" in the settings of both of these Elements, the data table shows the 22 and 1 features that should be reflected correctly as counts (see example screenshots below).


The feature service I'm using is a secure ArcGIS 10.4 service that has been registered to an ArcGIS Online organization. Do Operations Dashboard Elements support the counting of features/records in a related table from an ArcGIS 10.4 service with attachments enabled on them? Or is there a settings configuration that can be done on the service side to get the Indicator and Gauge Elements to display the correct feature/record count from a related table?

3 Replies
New Contributor

I have the same problem - I have a dashboard indicator set to filter a field by name, and no matter what I set the allowable values to my indicator shows 0. I can filter based on other fields, but the field I need won't work. Gauge shows the same thing - works for other fields, but not the one I need. For reference, the required field is a coded string type, and I have tried "Equals" and "Includes". I even tried "Does Not Include" and selected a few to test - the indicator shows the total number and does not change no matter how many I put in the "Does Not Include" field.

0 Kudos
New Contributor

Where you able to figure this out? If yes, can you please share your solution.

0 Kudos
by Anonymous User
Not applicable

I am also having issues with creating indicators from information in related tables. I set up a pie chart to show funding sources for various public projects that was included in a related table. When I was working in the configuration pane, the pie chart displayed perfectly, but as soon as I exited the configuration, a yellow warning symbol appeared on the pie chart element in my dashboard with a warning message saying "Cannot Access Data."

I have a similar issue with an indicator that is based on a related table. It will display the sum for the field I selected, but it will not filter when the map extent changes or when the selection in the related layer changes. I am wondering if related tables just aren't supported in dashboard indicators.

0 Kudos