Feature Layer - Import Problem (with Excel)

277
2
11-06-2021 06:49 AM
Tobias
by
New Contributor II

Hi all, 

I'm having a small problem with the "add data to feature layer" function: 

Background: unfortunately for us, we don't have server to get our data from. Thats why we are using Excel for some data entries. It usually works like a charm. However we are experiencing problems when some values reach "full numbers"

Example: Vaccination rates "1 time: 73,0%", "2 times: 72,8%"

The auto-add function does not see the 73,0 as a value. The Excel format is number with one decimal place. However Excel itself shows "73" (without decimal) 

Could this be the problem? The feature layer is formatted "double". Could it be, that in case of an integer, it does not see the value and therefore does not add it automatically?

 

Best regards

Tobias

0 Kudos
2 Replies
Daniel_McCulloch
Esri Contributor

Hi @Tobias 

Refer to ArcGIS field data types—ArcGIS Help | ArcGIS Desktop

Something that caught my eye is the use of a decimal comma. Try 1 time: "73.0%", "2 times: 72.8%"

0 Kudos
Tobias
by
New Contributor II

Hello Daniel, 

Switching between point and comma was my first guess. However: the problem only occurs when the value is round. I've discovered something else: 

When my system separator (Excel-> settings -> separator) is set to ".": As soon as I enter a round value, Excel changes the field value to "2" instead of "2.0". Regardless of whats on the spreadsheet. This could mean that AGOL does not use cell-format. Instead it uses just the cell value. 

So my work-around would be: if system standard is set to ",": manually type "60.0". This will lead to an incorrect field value in Excel, but AGOL seems to be able to translate it. 

Not sure, if that counts as a solution.

I think the problem may be the identifier in AGOL. If "5.0" is changed into "5" (Excel field value): AGOL interprets the value as integer (and is correct to do so!). But then the integer value does not meet any cells in my AGOL-Table. I have not found a way to force Excel to stop trimming the values yet...

Best regards

Tobias

0 Kudos