Editing geometry required?

2971
4
05-30-2013 05:06 AM
GregYetman
Occasional Contributor
Hi,

When trying to add feature layers to the operations dashboard it often crashes. I tried debugging it after the most recent crash and saw the exception below. The line "Message=Layer does not allow geometry updates" leads me to believe that adding a layer that does not have feature updates enabled is the problem. Must all layers permit feature updates?

TIA,

Greg


ESRI.ArcGIS.Client.FeatureService.ValidationException was unhandled
  HResult=-2146233088
  Message=Layer does not allow geometry updates.
  Source=ESRI.ArcGIS.Client
  StackTrace:
       at ESRI.ArcGIS.Client.FeatureLayer.g_GeometryChanged(Object sender, GeometryInstanceChangeEventArgs e)
       at ESRI.ArcGIS.AppCore.Widgets.Widgets.Map.MapWidgetViewModel.<RefreshGraphicsForMapExtent>d__8c.MoveNext()
    --- End of stack trace from previous location where exception was thrown ---
       at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
       at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
       at ESRI.ArcGIS.AppCore.Widgets.Widgets.Map.MapWidgetViewModel.<RefreshDynamicLayer>d__7c.MoveNext()
    --- End of stack trace from previous location where exception was thrown ---
       at System.Runtime.CompilerServices.AsyncMethodBuilderCore.<ThrowAsync>b__0(Object state)
       at System.Windows.Threading.ExceptionWrapper.InternalRealCall(Delegate callback, Object args, Int32 numArgs)
       at MS.Internal.Threading.ExceptionFilterHelper.TryCatchWhen(Object source, Delegate method, Object args, Int32 numArgs, Delegate catchHandler)
       at System.Windows.Threading.DispatcherOperation.InvokeImpl()
       at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
       at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
       at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
       at System.Windows.Threading.DispatcherOperation.Invoke()
       at System.Windows.Threading.Dispatcher.ProcessQueue()
       at System.Windows.Threading.Dispatcher.WndProcHook(IntPtr hwnd, Int32 msg, IntPtr wParam, IntPtr lParam, Boolean& handled)
       at MS.Win32.HwndWrapper.WndProc(IntPtr hwnd, Int32 msg, IntPtr wParam, IntPtr lParam, Boolean& handled)
       at MS.Win32.HwndSubclass.DispatcherCallbackOperation(Object o)
       at System.Windows.Threading.ExceptionWrapper.InternalRealCall(Delegate callback, Object args, Int32 numArgs)
       at MS.Internal.Threading.ExceptionFilterHelper.TryCatchWhen(Object source, Delegate method, Object args, Int32 numArgs, Delegate catchHandler)
       at System.Windows.Threading.Dispatcher.LegacyInvokeImpl(DispatcherPriority priority, TimeSpan timeout, Delegate method, Object args, Int32 numArgs)
       at MS.Win32.HwndSubclass.SubclassWndProc(IntPtr hwnd, Int32 msg, IntPtr wParam, IntPtr lParam)
       at MS.Win32.UnsafeNativeMethods.DispatchMessage(MSG& msg)
       at System.Windows.Threading.Dispatcher.PushFrameImpl(DispatcherFrame frame)
       at System.Windows.Application.RunInternal(Window window)
       at System.Windows.Application.Run()
       at ESRI.ArcGIS.OperationsDashboard.Internal.App.Main()
  InnerException: 
0 Kudos
4 Replies
TifPun
by
Occasional Contributor II
Hi Greg,

You mentioned that "adding a layer that does not have feature updates enabled is the problem", are you having a mix of editable and non-editable layers in your web map? Do they come from the same or different feature services? I have a webmap with a bunch of layers, the editable ones come from one feature service and the non-editable ones come from another service. I could add a new geometry to the editable layers, and no crash when I try to add a geometry to the non-editable ones (it just doesn't do anything). If you are doing it in a different way, do you mind giving more information about how you set up your webmap? Or, do you mind sharing some code snippet so we can look at it together?

Thanks

Tif
0 Kudos
GregYetman
Occasional Contributor
Hi Tif,

I had a mix of feature services in my map, some from ArcGIS Online that were editable and some from ArcGIS for Server that were not editable. I dropped a number (but not all) of the services that I had been including as data services when I authored the application and it was much more stable. The application was used for a demonstration, I haven't gone back to figure out what was going wrong. I will fire up the server services and have a look to see if I can reproduce the problem again and let you know.

Cheers,

Greg
0 Kudos
GregYetman
Occasional Contributor
I just re-created the dashboard view that was giving me problems and it seems to be working fine. I suspect that the most recent update to the dashboard (10.1.1.142) may of fixed whatever issue I had encountered.
0 Kudos
TifPun
by
Occasional Contributor II
Hi Greg,

As far as I know that build mainly addresses the installer issue, but glad to know it's working now! If you still see that problem please let us know.

Thanks

Tif
0 Kudos