Using tiledbasemaps.arcgis.com Services

3031
6
Jump to solution
03-26-2014 08:57 AM
JoeFlannery
Regular Contributor II
I have an ArcGIS Online for Organizations subscription and would like to test using the Collector for ArcGIS 10.2.2 app in a disconnected scenario.  I have created a map with a hosted feature service in the TOC, but cannot "Enable??? the Offline Mode in the map properties since I don't have a tiled basemap.  Following the Take Maps Offline help topic, I am trying to add the ???tiledbasemaps.arcgis.com/arcgis/rest/services/World_Topo_Map/MapServer??? service to the My Content area in my subscription.  I am challenged for a username and password in the process (see attached).  I used my AGOL credentials, which are an ???enterprise??? UN and PW, but I get an ???Error generating token??? message.

How do I add an ArcGIS tiled basemap service to My Content in AGOL for use in a Collector map?
Tags (2)
0 Kudos
1 Solution

Accepted Solutions
RussellRoberts1
Esri Frequent Contributor
You don't need to manually add the tiledbasemaps services into an AGOL web map. The app handles this when the map is enabled as offline with any of the esri basmaps except Open Street Map and the Bing basemaps. The web map needs to have all layers support sync and the offline button will be enabled when the map is saved.

Russ

View solution in original post

0 Kudos
6 Replies
RussellRoberts1
Esri Frequent Contributor
You don't need to manually add the tiledbasemaps services into an AGOL web map. The app handles this when the map is enabled as offline with any of the esri basmaps except Open Street Map and the Bing basemaps. The web map needs to have all layers support sync and the offline button will be enabled when the map is saved.

Russ
0 Kudos
by Anonymous User
Not applicable

Hi Russell

I understand that we should not add following layer under MyContent of ArcGIS Online because AGO basemaps are offline capable

https://tiledbasemaps.arcgis.com/arcgis/rest/services/World_Street_Map/MapServer 

However, we are using AGE portal for our organisation and i need a offline enabled basemap for collector but when i am adding this service under my content of AGE it is asking for the credentials and no credentials seems to be working here. May i know the reason why?? token error is coming but my AGE and AGO both are setup with SSO to our AD.

https://tiledbasemaps.arcgis.com/arcgis/rest/services/World_Street_Map/MapServer 

OR is this also not a suggested way? because esri page says otherwise

https://doc.arcgis.com/en/collector-classic/windows/create-maps/offline-map-prep.htm

please go through the last section of this url......Use an Esri basemap with ArcGIS Enterprise

BR

Saurabh

0 Kudos
JoeFlannery
Regular Contributor II
Russ:

Thank you very much for the clarification.  My map's Offline Mode was Disabled and I thought that I needed tiled basemaps.  I removed a Map Notes layer from my map table-of-contents and my map is now Offline Enabled!

Thank you.
0 Kudos
JoeFlannery
Regular Contributor II
Russ:

Got my first Collector disconnected map working!  Very exciting.
Thanks again.

Where are the voting tools in the Collector for ArcGIS forum threads?  I would like to mark this thread as Answered.
See attached.
0 Kudos
Kylie
by Esri Regular Contributor
Esri Regular Contributor
Hi Joe -- the voting and mark as answered options should appear now. Please let me know if you don't see them.
0 Kudos
JoeFlannery
Regular Contributor II
Kylie:

I see them now!  Russ' response is now marked as answered.

Thank you.
0 Kudos