Unable to Submit - Collector Error Message

1963
8
09-13-2019 07:08 AM
JohnSmith40
New Contributor III

Recently we've started seeing a "Unable to Submit - Unable to complete operation" error message when trying to submit our GPS data using Collector (v19.1.0, iOS v12.4.1). It's intermittent and the data will go through if we attempt to submit it again (however, sometimes it takes multiple attempts).

Anyone know what's going on? I'm not aware of any changes on our end that would correspond to this new error message. We've enjoyed collecting GPS data with Collector for years without experiencing this.

Any help is greatly appreciated.

Tags (1)
0 Kudos
8 Replies
RuiGe
by Esri Contributor
Esri Contributor

Hello, John, Is this for offline or online map? Do the features you submit have any related features or attachments? 

0 Kudos
JohnSmith40
New Contributor III

This is an online map and the features do not have any related features or attachments.

0 Kudos
erica_tefft
Occasional Contributor III

Hi Rui,

I am also seeing this error intermittently, however it is sporadic and hard to reproduce. I did some testing today, and this is what I've found:

  1. With an Administrator account, I don't see this error when submitting a new feature, or editing an existing feature (in any way).
  2. With a custom Publisher account (that has full editing control enabled), I saw this error when I edited an existing feature and tried to complete an attribute field that was blank to start with. If I edited an existing feature and changed an attribute field that was already populated, I did not get this error. Then, I was able to go back and edit again to complete a blank field.

I'm working with a hosted feature layer that has 4 related tables; all layers (point and 4 related tables) have attachments enabled, however the features I was editing did not have attachments and the new feature I added did not have an attachment. I was adding/editing features within the main point layer.

I have a few users who are having some issues with this. According to them, it only happens when working online in Collector. They said they are able to take the map offline, make the edits and don't see this error.

Also, this is not a new layer, we've been using it successfully in Collector all summer. This error has just started appearing within the last week or two.

Any help on resolving this would be great.

Thanks,

Erica

Erica
0 Kudos
RuiGe
by Esri Contributor
Esri Contributor

Hi, Erica

Thanks for providing the detailed information. I will try on my side see if I can repro the error in our org. 

0 Kudos
JasonSladinski1
New Contributor II

I have a similar but different error message that happens randomly.  It's happened 4 times today to one of our field techs and says "Unable to Submit reached end of data".  We have 13 techs in the field and only one has reported this today.

0 Kudos
RebekahPolette
New Contributor III

We are having the same problem but looks like the issue is within portal with the web maps  or WFL's

0 Kudos
AbrahamDowner1
New Contributor III

Also having this issue. Was there ever a resolution from the OP?

0 Kudos
RebekahPolette
New Contributor III

Hi Abraham Downer

From memory this problem (for us) was that when I was sharing a SQL referenced layer from Pro I needed to go into the configuration settings of the sharing/overwrite panel and specify zero elevation for z-values as the default for the feature layer.

0 Kudos