Trimble R1 fw5.09 not compatible with iOS v12.2?

971
4
04-23-2019 07:46 AM
BobWheeler
Occasional Contributor

Recently updated my Trimble R1 to the latest firmware 5.09 to comply with the GPS rollover issues.  I understand the R1 with this latest firmware is now is constant pairing mode.  The issue I am having is with my iPhone running iOS v12.2.  I am unable to connect with the latest version of iOS.  I have an iPad with iOS v12.1.4 and connecting to the Trimble R1 works like a charm.  I have newer ipads coming in soon and I'm afraid they won't work with the Trimble R1.  Anyone else experiencing this issue?

0 Kudos
4 Replies
BobWheeler
Occasional Contributor

Update - ipads running the latest iOS works great working with the R1.  I have been unable to get iphones with the latest version of iOS to connect via BT to the R1.

0 Kudos
KevinBurke
Esri Contributor

Hi Bob,

I am using an iPhone X running iOS 12.2 and I can successfully BT pair to an R1 running 5.09 for the firmware.

When you say that you cannot connect to the R1 on your iPhone, does it list the device but you just cannot pair to it, or it never lists the R1 to choose from in the BT list?

At this point, are you suspecting the issue to be iOS version related or due to the firmware update? In the past were you able to use that R1 successfully with those same iPhones?

Thanks

-Kevin

0 Kudos
JennieBishop
New Contributor

Hi there,

I am having this same (similar) issue and would appreciate any insight.  Since i have updated the firmware on my trimble R1 i can no successfully longer connect it to the iphone 6 (ios 12.3.1).  The trimble is updated to firmware 5.41 as of June 23, 2019.

The trimble will show up in the bluetooth, and will successfully connect.

When i open my gnss status utility app to find satellites i can again successfully see that i have an established bluetooth connection to the R1.  I cannot, however, connect to any satellites and my phone appears to be using the phone GPS instead of the trimble - despite being connected to the trimble via bluetooth.

The trimble additionally continues to flash with the yellow light, indicating it has not found satellites.

This is what i see in GNSS status:

Any help to get this back up and running will be greatly appreciated!

Cheers,

Jennie

0 Kudos
BobWheeler
Occasional Contributor

Hello Jennie - sorry for the late reply.  I never did resolve this issue with the iphone.  The iPad's worked without issue.  The problem just limited what I could use to map.  I haven't tried to connect since there has been a least 1 iOS update.  My R1s are still out in the field so I can't test either!

0 Kudos