Select to view content in your preferred language

Sync Error: Operation rolled back. What does it mean?

01-11-2017 03:42 PM
New Contributor III

We have been using Collector for about 18 months but have experienced a new error whilst attempting to sync offline edits.

Sync Error: Operation rolled back.

Once this error occurs, I have deleted one feature at a time and attempted to sync each time. At some point, I am able to sync successfully. The strange thing is that once this point is reached, I can re add the same feature type with the same attributes and I can successfully sync.


7 edits can't sync, 'Operation rolled back'. Remove 1 feature.

6 edits can't sync, 'Operation rolled back'. Remove 1 feature.

5 edits can't sync, 'Operation rolled back'. Remove 1 feature.

4 edits CAN sync, Add last feature that was removed. Success. Can sync.

Add 7 features. Sync Successful.

Each feature type can be synced successfully individually. Many can be synced successfully collectively.

Occurs on three different iPad Air 2's, using two different AGOL logins. Collector version 10.4.1. Latest iOS.

The project itself is fairly complicated with one to many relationships. Considering successful syncs, this shouldn't be an issue.

Operation Rolled Back? What does it mean?


0 Kudos
2 Replies
New Contributor

I have a very similar error, it seems to be when I have added related records in a table, but even once I delete the related record I still get the same error.

0 Kudos
Esri Notable Contributor

William - I don't have a definition of what "operation rollback" means but in reviewing Support Services incidents with similar error messages, I found a circumstance where it does happen.

  • Error reason (sometimes): User had overwritten feature service while data was still checked out on user's mobile devices in Collector for ArcGIS. If original feature service is not overwritten, this error does not occur.
  • Resolution:  Issue was data specific. Informed customer that she would want to recreate the data (not just the service) in order to resolve this issue.

Hope this helps!

0 Kudos