Sync error on Android

823
1
02-05-2019 04:07 AM
jorisfrenkel
Occasional Contributor II

I found a very strange bug with synchronizing attachments. It only happens with certain specific attachments, and only on Android phones, with feature services that have their credentials stored in ArcGIS Online. From around 60, or more, JPG images I tested, I found two that cause the error. The images are the same size as some other images I tested and that synchronized without problems, around 2 or 3 Mb.

I submitted the bug to our local ESRI support, and they put it through to Redlands, so I am hoping it will be solved. In the meantime I thought I might post it here, since it is a potentially very annoying bug that can be very hard to find.

The error says: An error occurred while synchronizing edits

Service = https://utiliy.arcgis.com/usrsvcs/services/....<rest service details>../FeatureServer: Server Error

0 Kudos
1 Reply
jorisfrenkel
Occasional Contributor II

An update on this issue:

ESRI Inc. managed to reproduce the problem with the problematic JPG's I forwarded to them. But they say they cannot reproduce the problem with a certaing workflow, so they will not do anything. Seems a really weird answer to me. They must be able to debug this, since it's their own software.

Since we didn't encounter any other cases so far, I haven't insisted for now. But let this be a warning notice to other users who have synchronisation problems on Android.

Maybe I should send a note to our head of state to reconsider the royal decoration Jack recently received.

Just joking of course. He deserves it :)

Regards,

Joris Frenkel, Staatsbosbeheer, the Netherlands

0 Kudos